I am trying to use the "node-red-contrib-bme280-rpi" to read a BME-280 pressure / temperature sensor using the I2C bus of a Rasberry PI.

The node appears to connect to the sensor. I did verify the sensor i.d. and its the same as showing on the Node-Red node.

Problem is, there is no data coming out of the node-red-contrib-bme280-rpi node???

Documentation is very skimpy.

Have others used this device and could you share with me the details for making it work?


Did you follow the instructions ? Did you restart node-red after installation of the node ?

ie. permissions

and what does your flow look like ?
node-red,npm and node js version?

As has been mentioned before, I'm not sure many people actually connect sensors direct to their Pi's. It generally seems much easier and more reliable to connect sensors to Arduino's or ESP8266/ESP32 devices.

Certainly I've used the BME-280 quite happily on an Arduino and more recently on the ESP8266. It is a good device and works well.


Thank - you for the reply

Yes, restarted and rebooted several times.

Screenshots attached:

I2C buss scan

Node Setup

Flow showing debug window (no output from the node)


Udate - Still Need Help

I noticed that bakman2 referenced a different node, node-red-contrip-bme28, so I gave this one a try:

First I followed the instructions to create a software based I2C bus. I completed those steps and rebooted, moved my clock and data to pins 23 and 24 then scanned the new bus 3. My sensor showed up at #77.

Added a trigger and output to the BME Node, still no output??

Screenshots attached:

I2C Bus Scan
Trigger Configuration
BME280 Node Configuration.

AlanBME280%20Configuration Trigger%20Configuration I2C%20Bus%203%20Scan

Your screenshot shows “muted” debug nodes?

and also bus number 7 rather than 3

ukmoose and bakman2

Thanks. Making progress.

Now, I get this message in the alarm panel:

"Sensor Init failed ->Error: ENOENT: no such file or directory, open '/dev/i2c-7'"

I went over the install instructions but couldn't find a reference to adding this file. Obviously I missed a step.



I followed these instructions to set up the software I2C bus as required by the Node install instructions:


try ls -l /dev/i2c*

Thanks, bakman for the help.

Ran the command, see the attached screenshot from the terminal.


Continue to get the error message:

Sensor Init failed ->Error: ENOENT: no such file or directory, open '/dev/i2c-7


Looks like we installed -1 and -3. Do the same for -7?


See attached screenshot of dev file contents. I can see that it has i2c-1 and i2c-3. How do I add i2c-7?


Looking at https://www.npmjs.com/package/bme280-sensor
Which is the underlaying code for the sensor, they use i2c-1 in their examples.

I'm not sure you need to add bus -7

You searched and found the sensor using
i2cdetect -y 3

but in the nodes config' you have entered Buss # 7 rather than 3

Followed those instructions. Moved the sensor back to bus 1. Rebooted. Now get this error message:

"Sensor Init failed ->Error: , Remote I/O error"

So.... a new genuine Adafruit BME280 sensor is arriving tomorrow. I will update the group after I try again, with a new sensor.


Thanks bakman and ukmoose.


Installed a new BME280 sensor from AdaFruit, installed on I2C-1, rebooted.....and it worked!


1 Like

How do I mark this "solved"??


If the option isn't available to you in the controls (...) for a reply, just edit the title and put "[Solved] " at the start.

1 Like