Sqlite nodes not working after update?

I have just tried to update sqlite and it gives me the message below. When I restart node-red the existing sqlite nodes are shown with errors? I also cannot see the nodes in the pallete. Everything else is up to date. Hopefully someone can point me in the right direction? Thanks

Here is the output:

pi@raspberrypi5:~/.node-red/node_modules $ npm install sqlite3
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

  • sqlite3@4.1.1
    updated 2 packages in 17s

25 packages are looking for funding
run npm fund for details

That isn't an error but a warning.

You need to post the errors from the Node-RED log

Hi,

  1. Can you confirm you have sqlite3 installed ? sudo apt-get install sqlite3
  2. how did you try to update sqlite3 node ?
  3. Did you run the update command in terminal from .node-red folder
  4. Did you try sudo infront of the command ? npm i --unsafe-perm node-red-node-sqlite
  5. What node.js version are you using ? you can check by running node -v

You appear to have installed the sqlite3 module, but that may not change the version that node-red-node-sqlite uses, assuming you are using that. I suggest installing the node-red-node-sqlite again to make sure it has a compatible version.

Hi There,

  1. Yes, sqlite3 is installed
  2. I have tried updating from:
    i. the pallet manager
    ii. the command line using npm install sqlite3 in the .node-red directory
  3. yes is was in the .node-red folder
  4. no, I have not done that, can you explain please?
  5. I am running node.js v12.20.1

"You need to post the errors from the Node-RED log" - where is that please?

Thanks,

Martyn

I am trying that now, I suspect that is the problem. I am rebuilding it now.

Are you trying to upgrade the npm module sqlite3 or are you trying to upgrade node-red-node-sqlite?

From the Documentation of the node

Run the following command in your Node-RED user directory - typically ~/.node-red

npm i --unsafe-perm node-red-node-sqlite

Note : the install process requires a compile of native code. This can take 15-20 minutes on devices like a Raspberry Pi - please be prepared to wait a long time. Also if node.js is upgraded at any point you will need to rebuild the native part manually, for example.

cd ~/.node-red
npm rebuild

[EDIT] forgot to ask whether you have restarted your node-red server after the update ?

I was just going through updating nodes after updating node-red. The updates were all successful but when I restarted node-red the sqlite node in my flow was not recognised. I have just deleted the node-red-node-sqlite and sqlite3 directories from node red and am rebuilding using

npm i --unsafe-perm node-red-node-sqlite

it is taking a while I will let you know how it goes,,,

okay, so I now have version 0.43 installed and it is working. However, pallete manager is saying there is an update 0.5. I will try again from the pallete manager.

All fixed, I have no idea what I did wrong but everything is good now. Thanks for your help