I'm bang up to date with Node-Red on my Pi 3, latest Dashboard, everything updated as expected using the palette mnager, except, not for the first time, SQLITE - problem is its a while since I updated this and I've forgotten how to get out of a jam with it.

node-red-node-sqlite has 2 nodes, I'm using 0.3.6 no problem, but when I tried updating it using palette Manager to 0.3.7 - the relevant flows stopped, citing 2 missing sqlite nodes. I've a half memory that in the past I had to wipe the SSQLITE folder - anyone come across this recently?

I hit a similar problem with missing files.
Nick told me to use...

npm rebuild sqlite3

It takes quite a while as it recompiles lots of things - but eventually it gets there.

Hope it helps.

Thats a good start, Dave. Is that AFTER updating or will that automatically get latest version and is that as you state or "sudo npm rebuild sqlite3" ? I'm guessing that would be done in the /home/pi directory?

I just typed it in as is.

I don't think it matters whether you are in the Node-RED directory.

I didn't use 'sudo', just typed it in as shown above.

You probably need to run it in ~/.node-red and do not use sudo

Thank you both - much appreciated....

Just for clarification then - for anyone else getting this, I managed to use the Palette Manager to completely update all my nodes, BUT when it came to the node-red-node-sqlite node (in this case 0.3.6 with 0.3.7 available) my SQLITE operations came to a halt. So, using a backup NR, in Palette Manager again, I installed node-red-node-sqlite 0.3.7 (at which point NR said it will be necessary to restart NR) - I STOPPED NR when the manager was done. I then went to the /home/pi/.node-red directory and ran "npm rebuild sqlite3" as user PI, then 10 minutes later when it was done recompiling, I started NR again and all is well. That worked.

1 Like