Switching Eth CIP for CIP-ST Node

Good Morning.
I'm trying to get the newer Ethernet-CIP-String node to read STRING tags from my Compact Logix.
I found another thread on this that suggested a resolve.

  • stop node-red
  • CD into the .node-red user dir
  • run npm remove node-red-contrib-cip-ethernet-ip
  • run npm install node-red-contrib-cip-st-ethernet-ip
  • start node-red

I'm looking for help with this. solution.

First off, how do I STOP node red? I have run the command "node-red-stop" in the CMD this in not recognized. What is the correct syntax?

Next, Step 2 says to CD into the .node-red user dir. What would this look like?

Lastly. Step 3 says. * run npm remove node-red-contrib-cip-ethernet-ip Do I simply put this into the CMD and run it there? Or do I need to have something before the command?

Thank you.

Apologies for the basic questions. I'm a PLC programmer by trade. I have a ton of data coming now into Node Red and using it in InfluxDB, Grafana and Groov Server but I'm lacking the Strings. I have WAY to many Ethernet Nodes already installed to delete them all manually to install the CIP-ST node in my pallet, so Id really like to get this option to work.

What OS/hardware are you running node-red on and how did you install node-red?

Im using Microsoft Windows 10 Enterprise on a basic PC.

Looking way back in my notes... I installed Node-Red by downloading. Going to CMD and
"npm install -g -unsafe-perm node-red"
Then Updates the NPM Version by CMD and "npm install npm --global"
I run node red by going CMD and "Node-Red"

What do you see in the command window when you run node-red? It should tell you there where the .node-red folder is.

It says C:\Users\avfplant>node-red

Don't you get any other output there? I would expect to see the node-red startup log.

There is lots here.
Under the "Welcome To Node-Red"
There is the version info, loading palette nodes, RED.Events,It shows the setting file, Context Store, User Directory, Projects Disabled, Flows File, Server Now Running. ETC.

What exactly am I looking for?

Thank you

You are looking for where it says the flows file, settings etc are. It should be a folder called .node-red under the user.

So break out of that, which will stop node red, cd into the .node-red folder, run the npm commands and start node-red again.

So I go to C:\Users\avfplant.node-red

"Break Out of that" what do you mean here?

Thanks

When you run the command node-red it starts node red. When you break out of that command, node red will stop. Ctrl-C should do it.

Im sorry Colin.
Call me whatever, but I don't understand what the break out of that command means. Where do I cntrl+c

You said earlier that when you start node red, using the command node-red you get the node red welcome message and lots of other stuff. You can stop node-red by typing CTRL-C in that window. How do you normally stop node-red?
CTRL_C means hold down CTRL and hit C

I haven stopped Node-Red before. This PC is always on datalogging since I installed it a year ago.
I tried cntrl+C in that window but I have no indication that anything stopped. I still see values changing in my Node Red development environment.

You said earlier that you started node-red by running that command and you see the startup messages. Do you see an error at the end of that output, saying that the port is already in use? If so then node red was already running when you tried to start it again. In which case you need to find how to stop node-red, which depends on how you set it up initially.

On second thoughts, to make it easy, just cd into the folder you identified earlier and run the npm commands. Then reboot and, if you have not set it up to start automatically, start node-red.

Iv had to re-start it only a few times when the computer had shut down due to a power failure or similar event.

The only errors I see in here have to do with the Groov Server Im writing to , I assume they are only there because I started Node-Red before Groov. I see no error regarding anything to do with the Port.

Colin.
I assume the ctrl+c worked as eventually it came up that the Node-Red Server wasn't responding.
I did run the commands and re-started the Node-Red.
The new Node is in my Palette and I should be good to go.

I very much appreciate the assistance AND your patience with me!

1 Like

Glad you got it working.