Systemd start-depencies and network access

I had problems using knx-easy - the problem was that knx-easy did't worked direct after a restart. The KNX access only worked after an node-red-restart.

My guess was that node-red starts too fast and wants to access the network too early. To verify this I extended the nodered.service file in the section [Unit] with the line "".

After that change everything works fine, reading and writing from KNX using the node-red-contrib-knx-easy node receive and transmit KNX messages.

My system is:
Raspberry Pi 4
Node-Red revision 1.0.3

Is the correct place to report a bug?

Best regards

There are those who don’t need a network so it’s not necessarily a bug

I think that might be considered a bug in the knx node, that it does not retry if the network is not ready when it starts up.
Consider the case when the network cable was unplugged for example. Do you want to hold the whole of node red just because one node cannot do anything?

1 Like

Hi dceejay and Colin,

you are right, I agree with you. For my installation the solution above is a acceptable workaround, but it is not a general solution.

I write an issue in the node-red-contrib-knx-easy GitHub.

There is an option in raspi-config - wait for network

Yes, but that isn't a reliable solution either.

As @Colin said, network failures can occur at any time.
Such cases need to be properly handled by the software, in this case the KNX node. So getting in contact with the developer would be the first place to start.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.