Task scheduler seems to hinder adminAuth


I use adminAuth in my settings file to secure node-red with username and password and this works perfectly fine, until I use task scheduler to autoboot node-red. When I do this I do not have to login anymore to go to my editor.

Does anyone know what is causing this problem?

Check the log output when running node-red using task scheduler to confirm it is using the right settings file. It is possible it is running as a different user, so is using a different userDir/settings file.

1 Like

Thank you! That solved my problem. For people with the same problem as me this is how I specified the settings file. In task manager go to the properties of the node red task, edit your "start a program" action and in add arguments enter -s path\to\your\settings\file