TCP Request VLC issue

Hi, I am trying to control VLC over remote control TCP or lua TCP with TCP nodes in node-red.
I have succesfully created a connection between node-red TCP Request (TCP out) nodes and the listener on VLC side.

The problem is when I inject the message command in node-red, it does not appear in RC console in VLC, unless I hit the deploy button in node-red. Then the command appears there with no errors and succesfully do what it has to do.

Any of the sides report no errors whatsoever. I am kinda new to this, but I cannot figure it on my own, even with looking around the forums.

Thanks for help. !


If you are sending commands and expecting a return (which I think you are) - then maybe try the tcp-request node - It may be more suitable. But yes once you change/edit your flow you must deploy it first before it will function.

Yes, I expect some return, so thanks for this, I have also tried it with request node. But I think you misunderstood my problem. I have established the connection between VLC and node-red via TCP (localhost:10001), that's OK. The problem comes when I try to send a command. I inject the message ('pause') and send it to one of the TCP nodes, but in VLC no message is recieved on port 10001. But when I make a little change (such as moving debug node a little) and then click deploy in node-red, the message from node-red ('pause') suprisingly appears in VLC remote control console and is performed with no errors.

So my deducation is that connection is working fine, but node-red only sends messages via TCP when I click deploy, which is strange.

It seems like I have some fault in options of tcp nodes, because when I inject my message 3 times and then do the same thing with deploying, it sends a buffer with string 'pausepausepause'.

I hope I managed to explain my problem more.

I have been using node-red for about 1,5 years, but i am new in the communication via TCP protocol.

I have solved it on my own. Problem really was in the settings of my TCP node. After each message I want to pass through the connection should close. There is a option in node TCP out to set it on true. That is why everytime when I deployed the flow, the message was sent. Because the connection closed.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.