Telnet output from geiger counter

I have a geiger counter which is outputting a telnet stream as follows:
CPS, 1, CPM, 13, uSv/hr, 0.07, SLOW
CPS, 0, CPM, 13, uSv/hr, 0.07, SLOW
CPS, 0, CPM, 13, uSv/hr, 0.07, SLOW
CPS, 0, CPM, 13, uSv/hr, 0.07, SLOW
CPS, 0, CPM, 13, uSv/hr, 0.07, SLOW
CPS, 0, CPM, 13, uSv/hr, 0.07, SLOW

There is no logon required just a connection to port 23
I’m not a programmer but have used node-red with some other sensors, sending data to emoncms for display. This, with much great help from the forum.
I don’t know how to set this up to capture the data. Looks like it should be simple but I haven’t figured it out yet. There is also an http stream on port 81 but I’m equally stumped on that.
Thanks in advance.

Have you tried the TCP in or request node set to port 23?

1 Like

Yes, thanks, I tried both but it didn’t connect. I guess I wasn’t setting it up correctly. Node-red is running on the rpi where I want to receive the data 192…176 and the telnet is running on an esp32 192…100:23. Do I need to send something to the source to start it? When I open a telnet session from a terminal then it starts sending automatically, no id or pw. Seems like this should be easy but somewhere I’m missing something.

I think you need to send a helo message but it has been a VERY long time since I had to do anything with raw telnet.

As an alternative, you can probably use an exec node to run telnet and get the output?

Since you are able to use telnet from the command line, you might try node-red-contrib-telnet-client.

[EDIT] My bad! These nodes loaded correctly in an earlier version of NR but seem to have a problem in the current one. I will look to see whether there is an easy fix.

Thanks, I tried to install but no luck. Seems to be there but not showing up in the list of nodes.

Did you restart the server and refresh the browser page ?

Duh! It needed the browser refresh.

I rebooted everything and cleared the browser but no luck so far. Maybe I didn’t install it properly…?

Some success in that after several restarts and reboots I have the telnet module installed and the nodes are showing under “network” in the left column.
However, trying various telnet nodes I am unable to connect with the host. There must not be an id/pw requirement as I can go from the command line telnet directly into the stream on port 23. Is there some sort of character that needs to be sent to connect? I haven’t been able to create a flow that deploys with a successful connection. Anyone have any suggestions here? Thanks in advance.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.