Unable to use Telnet on Raspberry Pi

Hi everyone,

I've got node red fired up on my raspberry pi and for the life of me I cannot get Telnet to work through NodeRed. Here is what I'm trying to do with telnet:
I have an audio DSP that I want to control through telnet, and have successfully controlled this DSP with telnet through other applications (including telnet through this RPI's terminal). For whatever reason I just cant seem to make it work through NodeRed. I get the error "Response wait exceeded timeout value (request 1500)"

Flow is here:

[{"id":"7774bffc.0fe27","type":"debug","z":"d6f410eb.bc592","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","statusVal":"","statusType":"auto","x":1270,"y":100,"wires":[]},{"id":"a754549d.ea27f8","type":"inject","z":"d6f410eb.bc592","name":"","props":[{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","payload":"Level1 increment level 1 1","payloadType":"str","x":850,"y":100,"wires":[["b11c8a52.3b57d8"]]},{"id":"b11c8a52.3b57d8","type":"telnet-request","z":"d6f410eb.bc592","name":"","connection":"2621e7b6.ff31f8","ending":"","endingType":"str","error":"error","x":1060,"y":100,"wires":[["7774bffc.0fe27"],["7774bffc.0fe27"],["7774bffc.0fe27"]]},{"id":"2621e7b6.ff31f8","type":"telnet-connection","name":"Tesira","address":"","port":"23","inDelimiter":"","outDelimiter":"\\r","timeOut":"1500","clearOut":"","openTries":"1"}]

Its waiting for a response by the look of it.

you could consider just using a tcp node and just blindly send it, that way it doesnt expect anything to come back.

Hi Lefty,

I've tried the TCP node to no avail, I've also tried multiple SSH blocks to no avail as well....

put sniffit on your pi

first do it manually within a telnet session.

and then do it with node-red and see what the differences are.

You realise you have to send carriage return and new line after each command?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.