The worst software ever created. I HATE YOU

Ive spent 1000s of hours setting up flows and all of a sudden I can only access the first page. I can see all my other flows but they are no longer clickable. If I disable my first flow the second one works but no other does. That this dynamically happened is pathetic. THIS IS COMPLETE CRAP... Ive spent 50 hours fighting this and have had enough. You all should be ashamed of this garbage.

Its some kind of UI bug between Windows 11 multimon and Node-Red. Im not going to waste anymore time.

Hello @mitchelr, welcome to the forum.

Why don't you tell us a little about your Node-Red installation (platform, version, any recent changes etc)
Maybe we can help. After all, it's a very friendly place.


...but you didn't think to ask for help here in the forum??

I'm not sure that you are asking for support now, or just taking a rude dig, when the problem could be a problem with your system, or your lack of knowledge and nothing to do with node-RED.
I would suggest that if you do want help & support that you perhaps moderate your comments and stop throwing insults.


It is a super simple installation with 6 flows that all work perfectly fine. All of a sudden the side menu simply wont click on anything. If I turn it on all the time I can click my other flows but then I have to look at that menu.. This is the most frustrating way to start the week imaginable.

I can reassure that there is no such general problem with node-red, either you have triggered a bug that has not been seen before (which is possible) or it may be something specific about your system or flows.
If you do want help trying to find what the problem is, and recovering your system, then as well as the information already suggested then I suggest restoring your flows file to the state it was before it went wrong and see if that helps.

Ive long ago reset every single working flow from backup. This simply happened to my working node-red and now I must look at that silly menu to have access to my flows again. What crap. So weirdly enough when the browser is full screen I lose this basic functionality. I normally run it in a window. Again total crap to have to go through this is 2021. This is like 1984 all over again. SO after all my frustration and wasted hours its simply WIndows11 and node-red simply not playing together OMFG... What complete crap by all involved.

Are you asking for help or not?
Remember that we are mostly keen users here trying to help each other. Posts like that will just put us off and remove any possibility that someone will try to help.

1 Like

No, its a bug between Windows 11 and Node-Red and they have stolen all of my patience. The software industry as a whole is completely broken.

It may be that you are the first to try it with Win 11 so that is not impossible. What browser are you using? Have you tried a different one?

Also, with node red running on the Win 11 machine, if you connect to node-red from a different machine, not running 11 (assuming that you have one) is it ok?

[Edit] You don't appear to have told us the node red or nodejs versions yet.

I'm afraid I never run Node-Red on Windows so I don't have any useful suggestions.

But a refreshing change between this software and a lot of the "mainstream" is that the people who maintain it often contribute to this forum. (So they already know that you hate them)!

@mitchelr please note that you have limited amount of posts to make at first day in here in forum so please be constructive, leave the frustration behind and do answer to the questions about the system setup as clear as you can.
Versions of all related pats are important. If there is bug somewhere - it can not just fixed if the setup can't be replicated or even investigated via searching world wide web for potential issues.

So fill the gaps for us and we try to help

OS - windows 11
Browser -
Node-RED version -
Nodejs version -
I see errors in browser console (Yes/No) -
I do expose my setup in public internet (Yes/No) -
(if you do expose)
I have taken all steps to secure my setup (Yes/No) -

And please - do not hate people before saying "Hello". This is friendly community, We do respect everyone.


Hi @anon53275575

That does sound strange and I can appreciate that would be unexpected and frustrating.

Are you aware of any changes/upgrades you may have made recently? It isn't going to have spontaneously broken. Maybe you've installed a new contrib node?

Could you have a look in your browser's JavaScript console for any error messages? That would help us narrow down what is going in here.

All I ask is you put aside the vitriol and anger. I appreciate your frustration, but let's help solve it constructively.


You should also try clearing the browser's cache then reloading the NR page.

This user sent a stream of extremely abusive messages to the admins demanding their account be deleted.

I have removed them from the forum and am locking this thread.

Thank you everyone who tried to help in good faith. They clearly weren't interested in our help.