Tibber API installation fails (Homematic)

Hello community

I am pretty new to Node-RED. Therefore, my apology for a probably silly question...

I tried to install the Tibber API node-red-contrib-tibber-api

Using the the installation menue of Node-RED I receive the error message "Cannot read property 'nodes' of null"

Using the command line "npm install node-red-contrib-tibber-api" I get a bunch of warnings but no error

pi@raspberrypi:~ $ npm install node-red-contrib-tibber-api
npm WARN saveError ENOENT: no such file or directory, open '/home/pi/package.json'
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN notsup Unsupported engine for node-red-contrib-tibber-api@5.2.2: wanted: {"node":">=14.0.0"} (current: {"node":"12.22.12","npm":"6.14.16"})
npm WARN notsup Not compatible with your version of node/npm: node-red-contrib-tibber-api@5.2.2
npm WARN enoent ENOENT: no such file or directory, open '/home/pi/package.json'
npm WARN pi No description
npm WARN pi No repository field.
npm WARN pi No README data
npm WARN pi No license field.

  • node-red-contrib-tibber-api@5.2.2
    added 29 packages from 26 contributors and audited 29 packages in 7.546s

11 packages are looking for funding
run npm fund for details

found 0 vulnerabilities

Does anyone have an idea what's wrong and how I can install the Tibber API?

I am running Node-RED inside of a Homematic installation on a Raspberry Pi 4.

Thanks a lot for your help


Welcome to the forums @Franz70.

If installing nodes via the command line, ensure you're doing so under the working directory that Node RED will use.

Under normal circumstance, that will be /home/pi/.node-red


cd ~/.node-red
npm install node-red-contrib-tibber-api

Lastly, the Node you are installing requires Node JS 14+, but your system is reporting Node 12.
I suggest updating your Node version, as the Node version you are using is extremely dated.

You can update Node RED and Node JS with

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) --node18

Thank you @marcus-j-davies for you help and recommendations.
I follwed your guidelide and everything worked well without error.
Now I canopen Node-RED via port 1880 but the Node-RED implementation embedded in Homematic "RedMatic" does still not show the Tibber nodes. The installation via the the menu in RedMatic gives still the same error.
It seems the problem is somehow related to the embedded version of Node-RED into Homematic.

Hi @Franz70

I took the liberty of installing the node(s) via the menu - and it installed fine, I suggest raising the issue with @hobbyquaker / GitHub - rdmtc/RedMatic: Node-RED packaged as Addon for the Homematic CCU3 and RaspberryMatic 🤹‍♂️

Note: Most on the forums use Node RED bare-metal, so won't have much insight into the inner workings of RedMatic

Screenshot 2023-10-14 at 21.56.55

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.