Trouble w/HTTP request node (ENOTFOUND)

#1

I am running into an error with the HTTP Request node in Node-RED. I am following this tutorial step-by-step, but I am not receiving expected results. Instead, I am seeing an ENOTFOUND error when the flow gets to the HTTP Request node.

Is anyone familiar with this ENOTFOUND error?

The flow that I am working with is pictured here:

0 Likes

#2

Are you using the same url that is mentioned in the tutorial (https://earthquake.usgs.gov/earthquakes/feed/v1.0/summary/significant_week.csv)?

What happens if you try to open that url in a browser on the same device running node-red? If that page returns a file to your browser, then it may be a typo in your request node’s config. If you export your flow and post it here, we can try it for ourselves.

0 Likes

#3

So its a little complicated… I am running Node-RED on my computer, but Node-RED was pre-installed onto a device called the MultiConnect Conduit (this could be the culprit for this issue).

Anyway, here is the exported flow that I am using:

[{“id”:“84b41468.4822d8”,“type”:“inject”,“name”:"",“topic”:"",“payload”:"",“payloadType”:“date”,“repeat”:"",“crontab”:"",“once”:false,“x”:100,“y”:52,“z”:“637e8c51.a041d4”,“wires”:[[“f5a565b.875da98”]]},{“id”:“f5a565b.875da98”,“type”:“http request”,“name”:"",“method”:“GET”,“ret”:“txt”,“url”:“https://earthquake.usgs.gov/earthquakes/feed/v1.0/summary/significant_week.csv",“x”:294,“y”:52,“z”:“637e8c51.a041d4”,“wires”:[[“b7f923db.698b3”]]},{“id”:“b7f923db.698b3”,“type”:“csv”,“name”:"",“sep”:",",“hdrin”:true,“hdrout”:"",“multi”:“one”,“ret”:"\r\n",“temp”:"",“x”:483,“y”:55,“z”:“637e8c51.a041d4”,“wires”:[[“63034279.3cc90c”,“66bbc310.aaacbc”]]},{“id”:“63034279.3cc90c”,“type”:“debug”,“name”:"",“active”:true,“console”:“true”,“complete”:“payload”,“x”:687,“y”:56,“z”:“637e8c51.a041d4”,“wires”:[]},{“id”:“66bbc310.aaacbc”,“type”:“switch”,“name”:"",“property”:“payload.mag”,“rules”:[{“t”:“gte”,“v”:“7”}],“checkall”:“true”,“outputs”:1,“x”:315,“y”:259,“z”:“637e8c51.a041d4”,“wires”:[[“35fec41b.5668bc”]]},{“id”:“35fec41b.5668bc”,“type”:“change”,“name”:"",“rules”:[{“t”:“set”,“p”:“payload”,“to”:“PANIC”}],“action”:"",“property”:"",“from”:"",“to”:"",“reg”:false,“x”:512,“y”:259,“z”:“637e8c51.a041d4”,“wires”:[[“75e1cf3c.721b9”]]},{“id”:“75e1cf3c.721b9”,“type”:“debug”,“name”:"",“active”:true,“console”:“true”,“complete”:“payload”,“x”:724,“y”:256,“z”:“637e8c51.a041d4”,"wires”:[]}]

0 Likes

#4

I’m going to take a stab here and guess that the Conduit device cannot resolve the DNS name for that site… can you try replacing the hostname earthquake.usgs.gov with its IP address 96.16.67.182?

0 Likes

#5

Just tried that. ENETUNREACH is the new error that is appearing...

0 Likes

#6

Sounds like that device is not set up to access the internet – maybe by design?
Does this thing have an OS that will allow you to ssh or rdp to it? If so, you can check the network settings, and possibly set the default gateway and DNS servers to enable it.

0 Likes

#7

I think you’re right. I am currently trying to setup an ssh with the box using PuTTy.

0 Likes