TypeError: Cannot read property 't' of undefined


When i try to connect throws this error please find a solution for this

You are really going to have to elaborate on the problem to get an answer.

Maybe post the flow?
Or the part of the flow that has the problem, at least.

Possibly you are passing it invalid messages. Show us how you have configured the node and also put a debug node showing what it going into it and show us what the debug node shows.

its accured part of the flow


its my flows

TypeError: Cannot read property 't' of undefined
at fileBrowserClient._inputCallback (D:\Vignesh\Personal\Node-red\installation.node-red\node_modules\node-red-contrib-filebrowser\filebrowser.js:74:47)
at fileBrowserClient.Node._emitInput (D:\Vignesh\Personal\Node-red\installation\node_modules@node-red\runtime\lib\nodes\Node.js:200:18)
at Immediate._onImmediate (D:\Vignesh\Personal\Node-red\installation\node_modules@node-red\runtime\lib\nodes\Node.js:179:33)
at processImmediate (internal/timers.js:456:21

So which node is causing the error?

What settings are in the "Repository" node?

What is coming out of the unnamed function before the file node? (Add a debug node set to show complete message)

Does the file you are attempting to load exist?

What account runs node-red and does that account have access to the file you are attempting to load?

Note: sometimes a screenshot is is enough, but there are a number of things we cannot figure out from just a screenshot of a flow.

1.Repository node : i given SMB shared loation username pass and folder name
2.function o/p : msg.payload="testing" ; msg.filename = "testing.txt"
3.i try to create file
4.i run node red as a service , and i given credentials thats creadentials had a access for read /write

If noone here has experience of the node (and it is not one I have seen mentioned before) you may well have to contact the author directly.

did you find a solution? I have the same problems.

Or another way to go to an SMB / CIFS network folder.

If you mount the network folder locally then you can access it like a normal folder.

I mapped the folder as z. But I get the following message
"failed to write to file: Error: ENOENT: no such file or directory, open 'Z: \ test.txt'"
I work with the file node.

file name Z:\test.txt

What account runs node red? Does that account have access to network share? Does it have file/folder permissions?

Note. Drive mapping is usually a per user thing so if node-red runs under system or another account it will have no awareness of your mapped drive.

I have account when i give a username and password.

When I look in task manager there is only 1 user active.

It runs node red under windows 10

Can you write to the file manually?
Try reading a file, that may show that you have some access.

As a service? or do you launch it in a cmd window?

CMD window

ok, have you tried a regular file node? That's what I use if the account running node-red has access to the share.

As a test try this flow (adjust the file name in the file node to suit)


[{"id":"59eb848a.3f5aec","type":"file","z":"e5771976.6bcf88","name":"","filename":"//SERVER/SHARE/test.txt","appendNewline":true,"createDir":false,"overwriteFile":"true","x":730,"y":260,"wires":[["2d31c491.f1b93c"]]},{"id":"9b23cf77.49b56","type":"inject","z":"e5771976.6bcf88","name":"","topic":"","payload":"this is a test","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":510,"y":260,"wires":[["59eb848a.3f5aec"]]}]

"failed to write to file: Error: UNKNOWN: unknown error, open '\\dtaustx\test.txt'"

I think it is an access control problem.
I have to put a user and password to map the folder.