ui_LED, dashboard and error 401


#21

Colin,

No, the "problem" doesn't go away if I do it from the CLI. The only difference is that from the WEB it just scrolls the vertical bars and then it isn't installed.

From the CLI, it goes through the motion and it says it is installed.
When I restart NR, and look at the pallet manager, it isn't. Sorry. It is.

But it doesn't work.


#22

I was still on the install issues. They were not fixed because Andrew had to resort to the command line again today.


#23

The uninstall problem went away. At one point you posted an error trying to remove it, that went away when you did it from the command line.
I have checked it isn't the node-red version that is the preventing the node working (since you have 0.19.4 and 0.19.5), the led node doesn't work for me on either version.


#24

@Trying_to_learn how are we supposed to read this sentence. It appears to contradict itself before it has finished. If you edit a post with new information, make it clear you are doing that.


#25

It was installed. It didn't/doesn't work.

For the sake of trying, I uninstalled it - with problems.

Then I had to reinstall it from the CLI too.

Alas doing that (just to eliminate it as a problem) didn't fix the problem.


#26

@Trying_to_learn which version of the dashboard are you using on each? It tells you in the startup log.


#27

Nick.

Yeah, I know. Sorry.

It did install from the CLI. I accidently said it didn't. I saw it and so edited it and corrected myself.

I shall have to be a bit more careful when replying I agree.

I thought I did put something in the edit field when I edited it.


#28

TimePi version 2.13.2 from pallet manager. (LED doesn't work)
me-desktop version 2.10.1 from pallet manager. (LED works)

See pictures


#29

The values from the log would have been fine.
Well it isn't the dashboard version either. I have tried with both on my system and on neither does the led respond to inputs.


#30

I was only wanting to make 100% sure I wasn't making a mistake.

I need to do it sometimes because one level of my error correction is failing so I apply the second level. Pictures say 1000 words too. Sometimes there are hints I miss on a screen grab.


#31

Does the mini-flow you posted work if you re-import that back into the working system?


#32

It was built on the working system and exported to the non-working one.


#33

Bed is calling.

Until tomorrow.


#34

OK, I have no further ideas then, unless someone else does. I have looked on github and there don't seem to be any similar issues against it, which is odd.


#35

I have submitted an issue on the node


#36

Hmm - (doesn't help much I know) - but - it works fine for me... :frowning:
node.js 10.14.1 - Node-RED 0.19.5, - node-red-dashboard 2.13.2
so unless we can recreate it's gong to be tricky.


#37

Can you suggest some debug I can stick in the source to get a clue? It is a very simple node, but I don't know how to go about debugging it? I have inspected the DOM and it seems to match what the code is doing, I can only think the message is not getting through or the id it is generating to reference the div it is wrong.


#38

Also, not wanting to complicate things:

(I have 3 machine with Dashboards. 2 RPI and 1 NUC)

I got the ui_LED to work on the second RPI with a dashboard.
This new machne is NR 0.19.4
Dashboard 2.13.2
Node 8.12.0


#39

@dceejay should I be able to insert console.log() statements into the client side code in the node and see the results in the browser console? I tried that but not getting any messages in the console.


#40

@Trying_to_learn which browser are you using for viewing the dashboard? Are you viewing both the working LED and the non-working one from the same computer with the same browser? If not then can you try that? Also try a different browser if possible.