Unable to install a worldmap node

Hello, I've created my Node-RED dashboard via Raspberry Pi. My Node-RED and my PI did not let me install the worldmap.

Like the other poster, I got the exact same error when I tried to install node-red-contrib-web-worldmap.

On my Pi directory, I have entered cd /home/pi/.node-red/ npm install node-red-contrib-web-worldmap. I only got a bunch of error dialogues as per screenshot below.


Any assistance much appreciated.

Does the PI have internet connectivity?
Is it behind a proxy?

Quick test - try ping and curl www.google.com - do you get a good response?

Is the pi connected to your network and the internet? Try
ping -c 3
which will ping google 3 times
[EDIT] Ahh @Steve-Mcl beet me by micro seconds!

1 Like

Makes a change Paul :stuck_out_tongue:

Hi @Steve-Mcl, @zenofmud
Thank you for the fast response!

Seems to me like my Pi is connected to my home network (not a proxy).

Any other idea why I cannot install the worldmap node?

Your device is not reaching the internet (3 errors) you need to fix that then you can install.

1 Like

Ahh ok, I didn't realise the 3 errors means my device doesn't reach the Internet.

I did everything in this website, but my Node-RED still doesn't install the worldmap. Could you kindly advise on any other way I can let my device connect to my Internet?

Is the pi connected to your router by wifi or by ethernet or not connected to the router at all?

It's connected to my router by wifi.

What do you see if you run

[Edit] Also what do you get for

[Further edit] Also probably worth posting /etc/wpa_supplicant/wpa_supplicant.conf and /etc/dhcpcd.conf Blank out any sensitive information obviously.

So here's what I got so far:



For the /etc/wpa_supplicant/wpa_supplicant.conf and /etc/dhcpcd.conf
I only got Permission denied.

You need to use

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
sudo cat /etc/dhcpcd.conf

1- Also what OS are you running on the Pi
2 - did you install NR using the bash script?

What came after that in the traceroute? It may take a little time to complete.
What to you see if you run the same traceroute in the PC? If you are using windows you might need to google to find how to do the equivalent on the PC.


For sudo cat /etc/wpa_supplicant/wpa_supplicant.conf, I got:

For sudo cat /etc/dhcpcd.conf I got a very lengthy response:

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
# Some non-RFC compliant DHCP servers do not reply with this set.
# In this case, comment out duid and enable clientid above.

# Persist interface configuration when dhcpcd exits.

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Respect the network MTU. This is applied to DHCP routes.
option interface_mtu

# Most distributions have NTP support.
#option ntp_servers

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate SLAAC address using the Hardware Address of the interface
#slaac hwaddr
# OR generate Stable Private IPv6 Addresses based from the DUID
slaac private

# Example static IP configuration:
#interface eth0
#static ip_address=MY HOME NETWORK

#static ip6_address=MY HOME NETWORK
#static routers=MY HOME NETWORK
#static domain_name_servers=MY HOME NETWORK

# It is possible to fall back to a static IP if DHCP fails:
# define static profile
#profile static_eth0
#static ip_address=my home network
#static routers=my home network
#static domain_name_servers=my home network

# fallback to static profile on eth0
#interface eth0
#fallback static_eth0

I'm on Windows 10 and yes, I used a bash script to install NR.
First I typed in

bash <(curl -sL

then sudo systemctl enable nodered.service , reboot sudo reboot

That all looks ok, I think we need the full response from the traceroute on pi and PC. something is blocking your internet access.

missing a default gateway and perhaps also missing a dns host setting

I did the traceroute on pi and PC (I assume you meant cmd?)

For the Pi, it looks the same old and the full response.

For the cmd