Unable to install new node in node-red - OpenWRT

Hi All,

I have successfully installed node-red on openwrt and was also able to create flows and its working perfectly.

But when I try to install new nodes such as sql etc.. I am facing an Illegal instruction] / rollbackFailedOptional: verb npm-session 513d559e2d002a53 error

this is happening with every node which I try to install.

Any suggestions ?


What happens if you try from the command line ? Can you show us the complete log ?

PFA of the screen shots of the errors from node-red UI and command line

command line error

Node-RED UI error

and what do you get if you try to install another node ? eg node-red-node-random ?
How did you get nodejs 12 installed on openwrt ? is there a package for that now ?

same result for even other node installations.I have tried with sql.
nodejs12 is available in the openwrt packages repository in master branch

sounds like that nodejs package has a bug in it then as npm should work from the command line without node-red - is it compiled for the architecture you are running on ?

Yes, I was able to compile.

when I run node v8.10, I am facing this error env: can't execute 'node': no such file or directory openwrt

any idea, why this is happening

We do have this apk for version 1.0.6 - https://github.com/dceejay/openwrt-node-red/tree/master/dist that uses the older default node+npm package

I was able to install node-red directly on my device but I am getting the same error. Ofcourse the node and node-npm are versions as before.
that uses the older default node+npm package - were you suggesting to use different version of node and node-npm ? Which version are you using ?

I think it drags in - https://openwrt.org/packages/pkgdata/node-npm

ok. I will check with 8.16 version. thats the only version left to check. rest I am facing some or the other errors.

any comment on this - when I run node v8.10, I am facing this error env: can't execute 'node': no such file or directory openwrt

nope - that's a node thing not Node-RED - I just use the package from the repo - you'd have to ask the OpenWRT project or package maintainer.

ok. yes, thats not a node-red thing. just wanted to know if you have faced any such.

I am facing the same issue when running node v8.16 as with node v8.10. env: can't execute 'node': no such file or directory openwrt.

Sorry - I think you are going to have to ask on an OpenWRT forum - probably more users over there.
what does just typing node -v and npm -v on the command line report ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.