Unable to install smart-nora

Hello, i am running nodered server on ibm cloud and unable to install smart-nora pallet. Earlier i was using google cloud successfully.

Welcome to the forum.

I had to google smart-nora... and once I realized your issue probably had nothing to do with a
"Proven snoring remedy" :stuck_out_tongue: I found your post on the contrib's git-hub page.

Unfortunately you didn't supply any more details there then you did here...


gauravmyid commented 42 minutes ago

I have tried installing multiple times but still doesn't work

So, perhaps you can supply more details needed to assist?

Version of Node-Red? (I know nothing about the IBM Cloud aspect of it)

Do you have any logs from the palette install?

Or can you copy/paste the terminal text showing any attempted npm install?

On that note... Have you tried running the npm command from within node-red's directory? ~/.node-red or whatever equivalent it may be with the IBM Cloud version.

I tried installing it from pallet manager. It shows to check log and showed this "Failed to install: node-red-contrib-smartnora

Install failed

Check the log for more information:

when checked log details it shows following message
"2021-08-17T08:21:04.634Z Install : node-red-contrib-smartnora 1.1.3

2021-08-17T08:21:05.923Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix="~" --production node-red-contrib-smartnora@1.1.3
2021-08-17T08:21:12.574Z rc=null"

Is that the entire log?

Unfortunately yes.

Well, even though it is of no use to me, I installed it, via pallet, to test the process... and it took around 5 minutes!! But it did install. And then about a minute to uninstall!

So all I can suggest is try it again via npm and let it run until it says it did or didn't work.

Nothing else I can do.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.