Unable to remove node from palette

I am trying to remove the node-red-node-google from pallette
I went in palette manager there was no "remove" option avaliable, I have made sure I had no node in any flow, also made sure there was no configuration node , i used the npm uninstall node-*red-node-google --save to remove everything from package.json, stopped and restarted node-red

after all this, if I go in the pallette manager, the package is still there with no "remove" options

Any help please

That doesn't look right. I would expect it would be npm uninstall node-red-node-google

Also, were you definitely in the .node-red folder?

And did you restart node-red after removing it manually.

If still no joy try using the search feature in the editor (Ctrl-F) and search for whatever the node name actually is that you select from the palette.

Typo error I meant I tried « npm uninstall node-red-node-google »

I was in the .node_red directory

I did stop and restart node-red

Searching for any related info gave me no results

It won't have a remove button if it was installed as a global module originally. Try running with the -g option:

npm uninstall -g node-red-node-google

Same problem, the node is still in the palette

What do these commands show
npm list node-red-node-google
npm list -g node-red-node-google

Then restart node-red, clear the cache in your browser and show us a screenshot of Manage Palette showing the node.
Is this a normal install or are you using Docker for example?

[Edit] If you are on a Linux system did you use sudo when you uninstalled with -g? If not then it should be
sudo npm uninstall -g node-red-node-google


This is a normal install on windows.
Here are the results of the two list command and the screenshot of the palette

Open the file .node-red/.config.nodes.json and search for the Google node. It should include the full path to where it's being loaded from.

It looks like it is installed in node_modules:

Run npm uninstall node-red-node-google, without -g, in your home directory to get rid of it.

Unfortunately that does not work, see the results:

You have run it in your .node-red directory again.

You need to run it one level up.

I tried it too and it still does not removed it ...

Then just manually delete the directory:


The c:\Users\bruno\node_modules\node-red-node-google doesn’t exist

Check the path listed in ~/.node-red/.config.nodes.json for the google node.

From the screenshot you shared, it showed Node-RED is loading the module from:


That tells us the module is installed in C:\Users\bruno\ so I would expect running the npm uninstall command in that directory would remove it.

You say c:\Users\bruno\node_modules\node-red-node-google doesn't exist... can you check the exact path as listed in the .node-red/.config.nodes.json file?

first thanks for all your time, I went back and check and there is definitly no node-red-node-google directory anywhere in the system (i did a search in the complete system)

So what does it say in ~/.node-red/.config.nodes.json ? that file gets updated every time Node-RED starts with an up to date list of where modules are being loaded from.