Uninstalling/Installing node-red-contrib-google-oauth2

Hi team,

I'm trying to use node-red-contrib-google-oauth2 to connect to the Google Analytics Reporting API v4. I'm stuck in a loop where I needed to uninstall and re-install the node. I have uninstall from the "manage palette" UI, as well as from the terminal but I'm left with the node in the below state:
image

Clicking remove gets me this error message:
image

And when I checked the log in the UI and in terminal, I'm not getting any indications of what's wrong/missing or any dependencies.

I've tried to restart the server hosting Node-Red, restart Node-Red itself, delete/reinstall JSON packages but have had no success.

Is there anything else you guys can think about?

Thank you,
JB

Open a terminal and go to your .node-red folder and run
npm remove node-red-contrib-google-oath2
and copy/paste the result here. Use the </> button at the top of the forum text window to paste it in.
Then do the same using install instead of uninstall.

[Edit] In fact before you do that run
npm list node-red-contrib-google-oath2
and
npm list -g node-red-contrib-google-oath2

Hey Colin,

Ran what you mentioned and got this:

-------------------------------------
~/.node-red$ npm list node-red-contrib-google-oath2
node-red-project@0.0.1 /home/ubuntu/.node-red
└── (empty)

~/.node-red$ npm list -g node-red-contrib-google-oath2
/usr/lib
└── (empty)

~/.node-red$ npm remove node-red-contrib-google-oath2
audited 372 packages in 2.595s

29 packages are looking for funding
  run `npm fund` for details

found 0 vulnerabilities
-------------------------------------

I'm still getting the same issue.

Thanks,
JB

You didn't run the final one, to try installing it again.

Edit: Just had a thought, you have restarted node red since you uninstalled haven't you?
Further edit: and also refreshed the page in the browser?

@jitrah Does the silence indicate that a restart fixed it?

@Colin We just got to it this morning. Got this:

-----------------------------------------------------------------------------
~/.node-red$ npm install node-red-contrib-google-oauth2
+ node-red-contrib-google-oauth2@0.3.2
added 25 packages from 24 contributors and audited 397 packages in 4.734s

29 packages are looking for funding
  run `npm fund` for details

found 3 high severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

~/.node-red$ npm list node-red-contrib-google-oath2
node-red-project@0.0.1 /home/ubuntu/.node-red
└── (empty)

-----------------------------------------------------------------------------

When I go to Manage Palette, I can see the nodes installed and enabled:

Screen Shot 2020-10-13 at 3.06.20 PM

However, when I search for the Google node to build a new flow, I can't find it:

Any idea of what a good next step would be?

The reason it doesn't show there is that you have a typo in the name.
First try refreshing the browser window, if that doesn't fix it then in a terminal run
node-red-stop
node-red-start
refresh the browser window again and see if that fixes it. If not then post the output of the stop/start here.