Update to 2.17.1 : missing node types

Sorry folks, little desaster (cold outside, central heating not running, WAF = 0.00) here for me:
I had a quite stable setup for my home automation system running on a PI3 and NodeRed. Today, I made the mistake, to update dashboard to 2.17.1 (don´t remember what it was befor). Now, I get this "Flows stopped due to missing node types" on various tokens (at the moment "ui_base").
At Node-Red startup, I already can see this in the NR console (marked yellow)

I guess, that my problem is, that I´m running node.js v6 and not v8 ? Is this true?
If so, how do I get in secure way from v6 to v8?
Or (second best): how can I roll back dashboard to a v6 compatible version?

THX for any help (I´m not the greatest linux freak)

You need to update nodejs, minimum version is 8.

It is easier to run the install script.

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)```

THX bakman2 !!

Will this also update NodeRed at the same time? Is this mandatory?

I´m really shy, leaving a stable platform and even more, loosing my scripts (I did the export of all flows, but...).

I think the script upgrades nodejs to v10 LTS.

I think it's worth doing. V8 is almost EOL and some nodes I've used don't work with V8 (not many and I can't remember which right now)

The script is very good and does pretty much every you need to be in a good running condition.

Not certain if it rebuilds so might be worth deleting node_modules folder from .node-red folder then do npm install (someone else might have more accurate info on whether the script does this for you but there is no harm in doing it)

Thanks to all!
The update worked: most nodes (ex. email) and all my flows got carried over.
I need to test now, whether all the hardware-near stuff is still working (I2C, timings,...).
Since I run safety critical hardware (oil burner, flame detector, exhaust valve,...) directly, I will do this very careful.

1 Like