Updated Raspberry PI now Dashboard polling-xhr.js POST 404

Hello Community,

I yesterday updated / upgraded my Raspberry PI 3.
Afterwards my Dashboard doesn't full load.
It stays black.

In Chrome I see that all GET requests like i.e.
http://192.168.178.68:1880/ui/data/?EIO=3&transport=polling&t=NTjlL2X
are successfull.
But all POST request like i.e.
http://192.168.178.68:1880/ui/data/?EIO=3&transport=polling&t=NTjlauS
fail.

Please save me!

Welcome to the forum @Gregor-Weissenborn.
In a terminal stop node red and start it again and then copy/paste the resulting log here. Copy/paste, not screenshot if possible please. When pasting it in use the <> button at the top of the forum entry window. You can stop/start node red using
node-red-stop
node-red-start

This is the output:

Start Node-RED

Once Node-RED has started, point a browser at http://192.168.178.68:1880
On Pi Node-RED works better with the Firefox or Chrome browser

Use sudo systemctl enable nodered.service to autostart Node-RED at every boot
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to http://flows.nodered.org

Starting as root systemd service.
Started Node-RED graphical event wiring tool.
4 Feb 17:47:02 - [info]
Willkommen bei Node-RED!

4 Feb 17:47:02 - [info] Node-RED Version: v1.2.6
4 Feb 17:47:02 - [info] Node.js Version: v12.20.1
4 Feb 17:47:02 - [info] Linux 4.19.108-v7+ arm LE
4 Feb 17:47:03 - [info] Paletten-Nodes werden geladen
4 Feb 17:47:10 - [info] [Dashboard] Started
4 Feb 17:47:10 - [info] Dashboard version 2.27.0 started at /ui
4 Feb 17:47:10 - [warn] ------------------------------------------------------
4 Feb 17:47:10 - [warn] [node-red-node-pi-sense-hat/sensehat] Error: Can't find Sense HAT python libraries. Run sudo apt-get install sense-hat
4 Feb 17:47:10 - [warn] ------------------------------------------------------
4 Feb 17:47:10 - [info] Einstellungsdatei: /root/.node-red/settings.js
4 Feb 17:47:10 - [info] Kontextspeicher: 'default' [ module=memory]
4 Feb 17:47:10 - [info] Benutzerverzeichnis: /root/.node-red
4 Feb 17:47:10 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false
4 Feb 17:47:10 - [info] Flow-Datei: /root/.node-red/flows_RaspberryPi3.json
4 Feb 17:47:10 - [info] Server wird jetzt auf ://127.0.0.1:1880/ ausgeführt.
4 Feb 17:47:11 - [warn]

Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt.
Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise
Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben.
Ihre Berechtigungsnachweise.
Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in
Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln.
Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

4 Feb 17:47:11 - [info] Flows starten
4 Feb 17:47:13 - [info] Flows gestartet
4 Feb 17:47:13 - [info] [mqtt-broker:Raspberry Pi] Verbindung zum Broker mqtt://localhost:1883 hergestellt.
Built in 13.81s.

That is generally not a good idea, though whether it has anything to do with the problem I don't know. Running as root means that an accidental mistake in the flow could wipe your system.
Presumably you must have run the node-red installation script as root.

Have you tried clearing the browser cache? I should have suggested that last time.

Yes emptied the cache and reloaded Ctrl+Shift+R.
No effect.
And it ran root all the time.
It seems that all the POST requests fail.

If you temporarily move the flows file away and restart node-red then it will create a new empty flow. Having done that can you then add a ui node and open the dashboard ok?

Edit, just thought of something else. When you say you updated, what was it that you did?

Tried that.
Removed the flows.
(BTW: Last node can't be deleted. You have to create a new empty one to delete the remaining other one)
Deployed
node-red-stop
node-red-start
Added uinode
Deployed
Reloded dashbord.
Same result.

I had made:
apt-get update
apt-get upgrade
shutdown -r now

That isn't what I suggested. Move the flows file away and restart node red.

If that doesn't help move the whole .node-red folder away. And restart node red.

Did you install node red using the recommended script from the docs?

Hello Colin,

everything is running well again. - Thank very much you for your help!

Deleting the flow files (in /root/.node-red) did not help.

But deleting the whole .node-red folder helped.
Even that caused me to reinstall all the palette nodes, reconfigure some config nodes, and reconfigure the dashboard theme.

But that was the way that brought the dashboard back to life.
(No plan what in the update/upgrade of my Raspberry Pi caused the Dashboard to be unstable.)

Thanks again!

Regards
Gregor

What does this command give?
apt policy nodejs

root@RaspberryPi3:~# apt policy nodejs
nodejs:
Installiert: 12.20.1-1nodesource1
Installationskandidat: 12.20.1-1nodesource1
Versionstabelle:
*** 12.20.1-1nodesource1 500
500 ://deb.nodesource.com/node_12.x stretch/main armhf Packages
100 /var/lib/dpkg/status
8.11.1~dfsg-2~bpo9+1 500
500 ://archive.raspberrypi.org/debian stretch/main armhf Packages
4.8.2~dfsg-1 500
500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages

Had to edit the links because of "new user rule -> Only one link per post."

That looks ok, I wanted to check where nodejs was installed from, in case your update and upgrade changed the major version. But assuming you didn't change anything else then I don't think it is that which caused the problem.

You could have saved some effort by copying the package.json from the original .node-red and running
npm install
which would have installed everything you had installed.
It would be interesting to compare the new package.json with the old to see if there are any differences. The order in there does not matter.

Next time then. :slightly_smiling_face:

Are you able to compare the package.json files?

I had deleted the .node-red folder without saving it. So I don't have the package.json file to compare it.
Next time then. :slightly_smiling_face:

That is a pity, it would have been good to understand what is going on for when someone else has a similar problem. It is difficult to do forensic analysis once the evidence has been destroyed.