Upgrade Node-RED


I just installed Node-RED on my UBUNTU 20.04 what I'm running on a Raspberry PI4.
I want to you Dashboard, but it says at the installation phase, that my Node-RED is too old (due to the fact, that I only installed it today).

So, I continued with upgrading the Node-RED to the latest version to be able to use the dashboard.

I used the description from here:
When I run the script:

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

I got the following issue:

I tried to check the help like this:

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)--help

but the terminal says "No such file or directory"

Could you tell me how I can upgrade to the latest Node-RED version to be able to use the Dashboard? It's really important for me, I would like to use this for a robot project which is the topic of my Master Thesis, what I have to finish until 10th of Dec!

Node-RED version: v10.19.0

You need a space before the extra parameters you're adding to the the bash command.

1 Like


Thank you!

Now I can see the help menu. What do you suggest, how should I proceed to upgrade my Node-RED?

As the message says, you need to update your node.js runtime.

Run the bash command with --node14 added (with a space before it!)

1 Like

I run to failure. It says now Npm is missing. I remember, that today I upgraded this, maybe without success.

From where I can get this?

It should have been installed as part of the node 14 install. But something has gone wrong. I'm not familiar enough with the script to suggest what has happened. Hopefully @dceejay can help.

Not sure why it didn’t uninstall node10. Are you using something like n or nvm to manage node installs ?

At this point I think you will need to manually uninstall the existing node and then retry the script.

It's called npm. I used this article as a guideline, because my setup is totally the same. Ubuntu 20.04 on a Raspberry.

The 'official' install guide would have been a better option to install node-RED - Running on Raspberry Pi : Node-RED
It would have been better supported, and the same script used to update your installation when they are published.

Hello Paul!

Basically I restored the system with backup option in Ubuntu. Then I tried again according to the guideline, what you propose. But I get the same fault.

" Install Node.js 14 LTS ✘ Bad install: Node.js v10.19.0 Npm missing - Exitcache "

How to get rid of this old V10.19.0 Node.js ultimately?

Have you tried

sudo apt-get remove nodejs
sudo apt-get purge nodejs
1 Like

...and then try the install script again.

I tried it as you wrote:


sudo apt-get remove nodejs
sudo apt-get purge nodejs


sudo apt-get remove nodejs sudo apt-get purge nodejs


bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) --node14

And I got the same.

I can't beleive this :confused:

What else can I do?


run once more

node -v
npm - v

if node - v gives you a version but npm doesnt as the Node-red script reports ..
then lets try the reverse and install it

sudo apt install npm

and re-run the official script .. you know the drill :wink:

You were right. I did not have npm. So I installed one with
sudo apt install npm
Then I ran the offical script again and it stopped at the same point with the same alarm message. I think this official script removes it, then it is complaining that it does not exist..

I tried 2 times with the same result. First install npm, check with

npm -v

Then run the official script, check again the

npm -v

and it's gone. I think the problem is in the official script! :smiley:

Any other option to update Node-RED?

Don't get dishearted!
It's a weekend when the node-RED team will be spending time with their families, but I'm sure @dceejay will offer some advice when he's next around.

Sure, no problem. I don't want to steal your family time!

The thing is during daytime I'm working, so for me the only options to have fun with Node-RED is nights and weekends. By the way, this part is not such a fun... (:

Just checking your question I do not use any n or NVM. Should I?

No, you shouldn't use n or nvm.

What does. which node report ?
What hardware/processor is this on ? It’s not 32 bit is it ?