UR robot TCP server


I am trying to set a TCP(server/client) connection between an UR robot and red-node but it seems that I don't know what I'm doing.

The robot routine is fairly simple. It opens a socket (TCP client) and checks that there is someone listing (it this case SocketTest Server application). If there is someone listening, the data is sent. If there is nobody listening is loop until someone is.

ie:robot routine:
Loop open≟ False

(see https://www.universal-robots.com/articles/ur-articles/tcpip-socket-communication-via-urscript/)

This works well with SocketTest (server); but when I try to use node-red's TCP nodes I have no luck establishing connection--and I really don't know why. I tried several of the online examples, but maybe I'm missing something. Any help would be great!


what have you tried. a tcp in node set to connect should work - but sometimes you may need root privileges to connect to low order ports (under 1024). If you have control over the far end you may want to try setting the tcp up on a higher port.

That worked--I have no idea about the low priority ports.
Thanks for the help.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.