Use control for openhab2 items does not find items

Hi @ all,

doing my first steps in NR and I am glad to say, it will improve! But now I have got an issue on openhab2 items. When I set up a control to OH no items are mentioned in the OH nodes. e.g.: in an openhab2.out which requires an item. So I am not able to address an item to be updated. Items are available and in OH everything works fine. Also some NR flows work fine. Do I have to set the path in the Controller?

All things I read start after the controller was set up....

Any questions are welcome. And also a solution.

Kind regards!

A newbie called Dirk...

Hello,

Which openhab 2 nodes are you using as there are several? node-red-contrib-openhab2 or node-red-contrib-openhab-v2? You can see which one you installed in the palette.
Are openhab and nodered running on the same machine?
Can you post a screenshot of how you set up the openhab controller connection in the nodes config?
You should have entered something like localhost:8080 if your running both on the same machine.
Have you configured the openhab rest api to use any authentication?
It would be helpful if you could answer those questions to troubleshoot your problem.

Johannes

Hi Johannes,

thanks for the quick answer!

Your questions:
The OH node is openhab2-out. Tried other nodes like openhab-v2-in. So I used openhab2-controller and openhab2-v2-controller. Same result.
The openhab2-controller is working in principle. I can gather the events coming from the events OH fires.
NR and OH are on the same machine: Raspberry 4.

The screenshot of the controller (hope it will work...):
image

I am not sure if I configured rest api with authentification. I found this link (changed to my environment) which workes:http://192.168.178.126:8080/rest/items?recursive=false
It showed all the items.

Does that answer your questions?

My first idea was that I do not use a standard path to the items. Could that be the case?

Thanks again and: Have a calm and nice christmas. (hope this fits to you...;-))

Kind Regards

Dirk_L

1 Like

Have you tried using localhost instead of the ip in the configuration in the host field as nodered and openhab are running on the same machine?

Edit:

So the node shows connected and receives events when you enter a item manually?

Do you see any errors in the side bar or in /var/log/syslog when you deploy?
Do you see any errors in the browser console when you open the node?

Hi Johannes,

that seems to be the problem. First test showed up items. So I will do a research, Maybe I will need two controllers, But I will see, or come back to this great forum!

Thanks for your help!

Dirk_L