Openhab2 'controller' not cleaned up - Debug connection errors non-stop

#1

I installed the Openhab2 node and configured a ‘controller’ to try and connect to an instance of OH i had running. I gave it a unique name and configured it to connect to local host (127.0.0.1). I didn’t spend much time trying to get this working and ultimately uninstalled the modules all together. I’ve now noticed in the debug window, i’m getting an error message once every second with the following string in the debug msg entry.
“ERROR {“type”:{“code”:“ECONNREFUSED”,“errno”:“ECONNREFUSED”,“syscall”:“connect”,“address”:“127.0.0.1”,“port”:8080}}”

Node-red or some remnant of the Openhab module is still trying to connect to the controller even though the Openhab nodes are uninstalled. I’ve restarted the machine Node-red is running on. I’ve restarted Node-red independently on that machine but nothing stops the messages. I’ve even reinstalled the Openhab2 Node and recreated more controllers with different names and now each of those are showing with the same error in the debug console. At this point I can’t even use the debug console any longer as it is overwhelmed with messages. I’ve disabled all flows, i’ve tried to show only debug messages from one specific flow and nothing makes a difference.

PLEASE HELP ME GET MY SANITY BACK

0 Likes

#2

When you deploy do you get an Unused Config Node message? If so then click on that and in the resulting sidebar display double click the config node show as unused and click delete.

0 Likes

#3

Thanks Colin. I had already tried that and the node wasn’t listed there.

However, I just decided to upgrade since I noticed I was several behind (17.5). After the reboot, the connection errors are no longer showing in my debug console so apparently upgrading solved the problem.

Thanks for your response.

0 Likes

#4

Do you mean there were some unused config nodes but not ones that seemed relevant? Note that the config node would not have the same name as the node that you installed that you place on the flow.

If so then did you delete them?

0 Likes

#5

Correct. I scoured through all unused and used config nodes. The one for the Openhab connector was not listed.

Update: Just to see if the problem was fully eliminated on the new upgrade of NR, I re-added the Openhab node just now and setup another dummy controller. I then started getting the connect errors in the debug tab. I then went back through the OH node and clicked to 'edit' the controller nodes and deleted the node that I had just added. I then deleted the node from the flow I had added it to and re-deployed. The connect errors are still happening so it appears I have re-created the problem.

To be clear, the dialog on the left is for adding a new controller. I had already added the one labeled 'OH_connector_controller' seen on the right. Those error messages are now the ones for the new test i've just referred to.

0 Likes

#6

One more update: I just rebooted again and this time, a reboot appears to have cleared the connect errors. Please trust me when I say that I had rebooted several times when this was happening the first time before the upgrade.

I wonder if it has something to do with the fact that I setup the dummy controller to connect to localhost versus an external IP/DNS name?

0 Likes