Strange debug message. Where is it coming from?

#1

I imported a few nodes that had a Home Assistant node in it to help someone understand his flow. Did that, then deleted the nodes. But now, I am getting this error: Is there ANY way to determine what node could be trying to connect to duckdns? I have looked at every node in every flow and can't find the offending node. I even tried rebooting the Raspberry this instance of Node-red is on. I went to "Selected Nodes" in the Debug tab and unticked everything, but I am still getting this error. Debug is useless as I am getting this error every second.

Help??

8/4/2018, 11:34:44 PM  Home Assistant
msg : string[165]
"Home assistant connection failed with error: Connection to home assistant could not be established with config: https://MyDomain.duckdns.org:8123 <password redacted>"

Sig

0 Likes

#2

When you deploy do you get a message about unused configuration nodes? If so then that is the problem.

0 Likes

#3

As Colin suggests, you may still have a HA config node lurking in the background.

If you open the configuration nodes sidebar from the drop-down menu, look for any home assistant nodes in there. If there is one, double click it and hit the delete button to remove it.

0 Likes

#4

Thanks Colin and Knolleary- This is one of the first tings I thought of, but there is no 'unused configuration nodes' warning on deploy, and the only 'HomeAssistant' nodes are my own:

I could try removing all 32 of my Home Assistant nodes and reinstall them, but there's no guarantee that this would work. The worst case would be to remove Node-Red from Home Assistant and reinstall NR from scratch. But if I just export/import my flows, will this phantom come back?

Where else can I look?

0 Likes

#5

You could search your nodes (using menu option) for MyDomain to see if any of your nodes contain that. Or open your flow file in a text editor and do likewise.

0 Likes

#6

Ah, I misunderstood, I thought you had deleted all HA nodes. I presume therefore that you did have your domain at duckdns configured at one point.
Have you tried restarting node-red? Perhaps deleting a node has left something running.

0 Likes

#7

First, I did reboot the Raspberry at the command line - no change.
I did export everything and look at the flows text file for the offending link- nothing there. (Also, when I selected "All Nodes" and deselected everything, the error continued).

One last try- I did a cold-boot. Shutdown from the command line then unplug the power to the Pi.

Plug-in, reboot, and now, the offending message is gone. Apparently there was something in RAM that survived a warm-reboot.

Thanks for the assistance- it is greatly appreciated. Note that this Node-red is running on hass.io, not Raspian. The last time this happened with Node-red on my Raspian, deleting the offending flow or node always fixed it. So you can appreciate why this one was so confounding.

(And, BTW, I've never used DuckDNS).

Sig

0 Likes

#8

When you said the error contains "MyDomain.duckdns.org:8123" was that literally MyDomain or was it your domain? I assumed the latter. I now suspect it was the former. I imagine this is some default in something somewhere.
I have great difficulty understanding how a reboot without power cycle had a different effect in this respect to a power cycle. I think I will steer clear of hass.io if (as you suggest) it has a habit of presenting you with such issues.

0 Likes

#9

Easy mistake. This was the address in the other user's Home Assistant node. Why it didn't go away when I deleted his flow mysterifies me. I have had other "oddities" in hass.io that only cleaned up with a cold boot, so it will likely be my default tool in that Pi.

0 Likes