V1.2.2 in QNap Docker - Issue

I've been using NR within QNap's Container Station for some time time now, never usually see any issues with upgrading versions. Although I'll happily admit that if the GUI doesn't work I'm a bit stuck as to how to fault-find on the Qnap implementation.

I'm currently on v1.1.3-12-AMD64 but seem unable to move to v1.2.2-12-AMD64.

With all settings identical and pointing at the same shared folder on the QNap I get this error during startup:-

[error] Error: EPERM: operation not permitted, copyfile '/data/.config.nodes.json' -> 'data/.config.nodes.json.backup'

Reverting to v1.1.3 and everything just works fine again.

I've tried installing v1.2.2 to a new shared folder (to take existing config out of the equation) and that still doesn't work, here's the log output for that attempt :-1:

0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli '/usr/local/bin/node',
1 verbose cli '/usr/local/bin/npm',
1 verbose cli 'start',
1 verbose cli '--cache',
1 verbose cli '/data/.npm',
1 verbose cli '--',
1 verbose cli '--userDir',
1 verbose cli '/data'
1 verbose cli ]
2 info using npm@6.14.8
3 info using node@v12.19.0
4 verbose config Skipping project config: /usr/src/node-red/.npmrc. (matches userconfig)
5 verbose run-script [ 'prestart', 'start', 'poststart' ]
6 info lifecycle node-red-docker@1.2.2~prestart: node-red-docker@1.2.2
7 info lifecycle node-red-docker@1.2.2~start: node-red-docker@1.2.2
8 verbose lifecycle node-red-docker@1.2.2~start: unsafe-perm in lifecycle true
9 verbose lifecycle node-red-docker@1.2.2~start: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/src/node-red/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
10 verbose lifecycle node-red-docker@1.2.2~start: CWD: /usr/src/node-red
11 silly lifecycle node-red-docker@1.2.2~start: Args: [
11 silly lifecycle '-c',
11 silly lifecycle 'node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"'
11 silly lifecycle ]
12 silly lifecycle node-red-docker@1.2.2~start: Returned: code: 1 signal: null
13 info lifecycle node-red-docker@1.2.2~start: Failed to exec start script
14 verbose stack Error: node-red-docker@1.2.2 start: node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"
14 verbose stack Exit status 1
14 verbose stack at EventEmitter. (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
14 verbose stack at EventEmitter.emit (events.js:314:20)
14 verbose stack at ChildProcess. (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
14 verbose stack at ChildProcess.emit (events.js:314:20)
14 verbose stack at maybeClose (internal/child_process.js:1021:16)
14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
15 verbose pkgid node-red-docker@1.2.2
16 verbose cwd /usr/src/node-red
17 verbose Linux 4.14.24-qnap
18 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "start" "--cache" "/data/.npm" "--" "--userDir" "/data"
19 verbose node v12.19.0
20 verbose npm v6.14.8
21 error code ELIFECYCLE
22 error errno 1
23 error node-red-docker@1.2.2 start: node $NODE_OPTIONS node_modules/node-red/red.js $FLOWS "--userDir" "/data"
23 error Exit status 1
24 error Failed at the node-red-docker@1.2.2 start script.
24 error This is probably not a problem with npm. There is likely additional logging output above.
25 verbose exit [ 1, true ]

Any thoughts as to what's going on for me please ?

Cheers,
Ian

Same here

My first theory was that there is a permission issue with /data, but this changed long before the latest version. I downgraded to
nodered/node-red:1.1.3-12-amd64 and it runs without any issue.

Note : Users migrating from version 0.20 to 1.0 will need to ensure that any existing /data directory has the correct ownership. As of 1.0 this needs to be 1000:1000 . This can be forced by the command sudo chown -R 1000:1000 path/to/your/node-red/data

I've not had any joy finding whats up - would be nice for somebody with a bit more experience to maybe offer up some suggestions ?

How about Synology users - is 1.2.2 working inside Docker on your devices ?

I've attempted the command referenced by windkh above...once again it makes no difference, same error message...looks like us Qnap owners are stuck with v1.1.3 for now...