Wait until Node - Bug? Timeout definition

Hello,

i'm trying to put the custom timeout in Wait until Node.

In best way i would like to out there a msg.data.timeout or somtrhing like this. But it do not work.
image

I have read manual

and tried to do this way. But it also do not work. Here if inject Node

All the same it do not override given timeout.

Is it a bug in Wait until Node or i'm doing smth wrong?

Here is the complete code


[{"id":"cf239ad9.c76598","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"7b200786.6e8a88","type":"inject","z":"cf239ad9.c76598","name":"","props":[{"p":"payload.timeout","v":"5","vt":"num"},{"p":"payload.timeoutUnits","v":"seconds","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"","x":200,"y":210,"wires":[["ed6806b2.ea1bd8","88f77850.edce78"]]},{"id":"ed6806b2.ea1bd8","type":"debug","z":"cf239ad9.c76598","name":"1","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","statusVal":"","statusType":"auto","x":470,"y":135,"wires":[]},{"id":"bcf5d455.be4718","type":"debug","z":"cf239ad9.c76598","name":"2","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","statusVal":"","statusType":"auto","x":515,"y":285,"wires":[]},{"id":"1c399e9c.2c8f91","type":"function","z":"cf239ad9.c76598","name":"Cancellation Message","func":"msg.tts = {}\nmsg.tts.message = \"Действие отменено!\"\nmsg.tts.speaker = \"media_player.google_home_mini_livingroom\"\nreturn msg;","outputs":1,"noerr":0,"initialize":"","finalize":"","x":610,"y":195,"wires":[["ed6806b2.ea1bd8"]]},{"id":"88f77850.edce78","type":"ha-wait-until","z":"cf239ad9.c76598","name":"CANCEL Action","server":"63f11f83.adf4c","outputs":2,"entityId":"script.system_cancel_trigger","entityIdFilterType":"exact","property":"state","comparator":"is","value":"on","valueType":"str","timeout":"111","timeoutType":"num","timeoutUnits":"seconds","entityLocation":"","entityLocationType":"none","checkCurrentState":true,"blockInputOverrides":true,"x":380,"y":210,"wires":[["1c399e9c.2c8f91","ed6806b2.ea1bd8"],[]]},{"id":"63f11f83.adf4c","type":"server","z":"","name":"Home Assistant","legacy":false,"addon":false,"rejectUnauthorizedCerts":true,"ha_boolean":"y|yes|true|on|home|open","connectionDelay":true,"cacheJson":true}]

Thanks a lot!

It make it difficult for people to help if you don't declare the full name of the node.

I just looked in the library and entered wait and did not see anything like wait and until.

This looks like a misunderstanding and explanation of what is wanted/expected.

It is wanting msg.payload.timeout and msg.payload.timeoutUnits from where I stand.

Though the error message says:

{{data.timeout}}

Try the way I suggested.

(And the full name of the node)

click the dropdown - choose msg & then enter data.timeout

If you view the 8th video in the excellent "node-red essentials" playlist, at about the 1:10 mark, you will see where Nick hovers over the debug message and copies the path to an item.

that is essentially what you need to do to get the path to the value you are interested in

1 Like

As i said it is Wait Until Node - sorry i do not know where to find the full name of it. Looks like standart Node, as for me i did not installed it, it was in package.

First of all i thought also this way, but, please take a look at it

In my explanation on next step i did it, but without susscess

Well, I can't find such a node in my pallet.

So I can't help you further than this.

Open your pallet manager and find the node.
Take a screen show and post it so the full name of the node can be seen.

Here is what I see if I go to the library and search for wait.

None of those are this wait until node.

My apologies, I thought it was a different node.

Is this a home assistant node? If so, have you tried asking on the HA forum?

I understood, it it in package of Home Assistant

I solved it!


It must be of course unchecked!