[warning]Bullseye OS released for Raspberry Pi

so watch out @dceejay in case the script needs tweaking :slight_smile:

3 Likes

Doesn't Kernel 5.1 introduce a new way to access GPIO's too? I seem to remember seeing something a few weeks back. I'll see if I can find the article.

I was wrong, it's 5.11.

DON'T PANIC
Luckily, the main OS is still using 5.10

Its currently at 5.10.63

I just was trying to install 2.1.3 into a fresh Raspberry Pi OS, Bullseye.
The install proceeds but gives an error:

This can take 20-30 minutes on the slower Pi versions - please wait.

  Stop Node-RED                       ✔
  Remove old version of Node-RED      ✔
  Remove old version of Node.js       ✔   
  Install Node.js 14 LTS              ✔   v14.18.1   Npm 6.14.15
  Clean npm cache                     ✔
  Install Node-RED core               ✔   2.1.3 
  Move global nodes to local          -
  Npm rebuild existing nodes          ✔
  Install extra Pi nodes              ✔
  Add shortcut commands               ✘
sed: can't read /lib/systemd/system/nodered.service: No such file or directory
sed: can't read /lib/systemd/system/nodered.service: No such file or directory
  Update systemd script               ✔
Any errors will be logged to   /var/log/nodered-install.log

And indeed there is no shortcut for node-red-start.

Any ideas on how to fix? @dceejay

mm - your install seems to have gone differently to the way mine did (PiZeroW2)

image

Did you apt update/upgrade before installing Node-RED?

Also, does that file exist and if so, what is in it?

Can you post that file please.

Most odd... I have done multiple installs of Bullseye this week (update of old, clean install minimal and normal versions, Pi0,1,2 and 3, and 64bit version) - all worked fine with latest install script.
Do you have a link to the exact version you are using ? and which hardware ?

I will try again, I wiped the SD card that I used to try this.

This is a Model 3 B+ circa 2017. The SD card was initialized from the Pi Image App but I used the advanced option to set ssh on with a new password and a default set of WiFi credentials with a change in WiFi country to US and a Locale of US/New York, US keyboard.

I did an apt update and full-upgrade BEFORE trying the node-RED script.

I will do the script before an OS image update/upgrade this time.

And the executable node-red-start was NOT found after the failure I reported above.

I will try again and retrieve the log and share here. If the install fails.

1 Like

Continuing my journey...

The script worked when I did not first do the apt update and full-upgrade. I only used one Pi Imager advanced option to enable ssh. I kept the default password and did not do any wifi setup or change locale/keyboard through the Imager preferences.

I will now repeat with the same choices as yesterday that led to the failure I reported.

I will save this instance's install log just to compare.

1 Like

When I asked about whether the file exists, I meant the file it complained about in the error.
Did you keep the log from the first time, a clue should be in there.
The 'correct' way is to update the system then run the script, so if that did not work for you then something odd is going on. Are you sure it is a good SD card?

I am about to retry with the first sequence of steps that failed. For this time (which worked) I used the same SD card as yesterday so I think the SD card itself is fine.

Stay tuned.

Now, with the same setup steps as yesterday, there was no error. No problem with the Add shortcut commands step.

So it might have been something temporary??

Since I can't reproduce, I guess there is nothing to do at this point. I wish I had saved the original log.

1 Like

Might be something to do with a recent update that caused the original failure but probably just a glitch in the matrix :slight_smile:

We'll see if anyone else reports it in

I still suspect the card. In your situation I would chuck it. Otherwise it may fail in a months time when you hit the bad bit again. Is it worth taking the risk for a few pounds? If you do keep it then make sure everything important is regularly backed up.
However, I suppose it is conceivable that a temporary internet failure on the previous step might not be caught by the script and might show itself at the next step in the script, giving the error you saw.

Thanks for the advice. I did switch cards this morning since I used yesterday's to restore a Buster install. That worked just fine. Today's card has seen the two bullseye installs I documented here, both of which were successful.

I can warn my students about this SD card corruption possibility for future failed installs.

It isn't something that happens particularly during installs, it is more likely to appear during normal use. However, provided you buy good branded cards from a reputable supplier (so you can be reasonably confident they are really what they say they are), modern cards are extremely reliable. I have one in a Pi running my heating system that has been working perfectly for over 5 years continuously.