Watson STT & TTS "Send is not a function"

I'm trying to work through the Watson project to create a voice enabled Covid-19 chatbot using node-red (https://developer.ibm.com/tutorials/create-a-voice-enabled-covid-19-chatbot-using-node-red/) but cannot get the STT or TTS modules to work. They both fail with a message indicating that "send is not a function" . The console log advises that we had ....UnhandledPromiseRejectionWarning: TypeError: done is not a function
at /Users/donald/.node-red/node_modules/node-red-node-watson/services/text_to_speech/v1.js:196:9 and so on.
I don't believe my Watson STT and TTS instances are at fault as I can run the speech recognition demo and the sample curl programs which can be found elsewhere on IBM.com. I'm guessing it's somewhere in node-red but I'm not sure how to diagnose... Anyone else experiencing the same ?

@radioman192 can you share how you have configured the nodes? Will probably need @chughts to suggest something.

This will be because the Watson nodes are now Node-RED 1.x compliant. You will need to upgrade Node-RED to at least 1.0.0. They have been tested on 1.0.3

I thought all my node-red instances were at the latest level but on checking my main one I see it says "0.20.6" which I need to investigate.

doh!! It seems to be working now. (Apart from not getting my accent too well - Watson clearly wasn't tested by Groundskeeper Willy!!!)

Thank you so much for the push in the right direction...

This needs work. Audio from the microphone of my MacBook goes to Watson via STT but doesn't always get transcribed accurately whereas if I record a wav file using the same microphone and send it as a file to STT it has a much higher chance of being transcribed accurately..... I've yet to try this on a RPi with microphone array so we'll see how that works.

In the meantime, I've discovered something else that might be release related...
Watson Assistant does not respond to an accurately transcribed phrase (like "What is corona virus". It consistently responds with "Resource not found" and I'm pretty certain the node is configured correctly. The console log shows that Assistant is V1. Is this correct? Looking at github the inference is that Assistant should be V2.
Should I have re-installed the Watson package when I upgraded Node-Red?

Opened eyes and note that there is already a V2 Assistant node in the palette. Tried ... no difference
Also tried Assistant Lite - same result :frowning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.