Webhook to http-in

Hi all, I'm trying to configure a Webhook to send data directly to myNodeRed env.
I have set up a http-in in my NodeRed environment, exposed the env. to internet and tried to send data from Postman against the internet exposed URL and everything works as expected, http-in responds.

As another test I've used Slack's ability to set "Outgoing webhooks" app configured it to send to the same URL as when trying from Postman but nothing happens in NodeRed..
Any one with experience or ideas regarding this?

I don't understand why the http-in don't react to the Webhook POST from Slack, I have tried an online service for webhooks and Slack are sending the post to that service, no problems.

Isn't this supported by the http-in node in NodeRed?

BR
Kjell Brandes

you probably set the http in node as GET, so a POST would be ignored.

It is in POST mode..
I've actually have two http-in set up, one GET and one POST, just to be sure :slight_smile:

Kjell

And a debug after http in set to complete message object produces what info.

Thats the thing, the debug is dead silent when the POST comes, or should come from Slack.

can you show slack setup

also try using rester addon in browser. I know it on firefox not sure if it is on other browsers. Can you share your flow as there may be a simple typo to.

This is the flow I'm using....

[{"id":"26e71535.11087a","type":"http in","z":"86c72ff3.5f4c4","name":"","url":"/slack","method":"post","upload":false,"swaggerDoc":"","x":630,"y":520,"wires":[["df54fc29.ad0cb","ed75bc34.bca2b","576cb4cb.446f2c"]]},{"id":"ed75bc34.bca2b","type":"http response","z":"86c72ff3.5f4c4","name":"response","statusCode":"200","headers":{},"x":950,"y":470,"wires":[]},{"id":"df54fc29.ad0cb","type":"debug","z":"86c72ff3.5f4c4","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","statusVal":"","statusType":"auto","x":870,"y":660,"wires":[]},{"id":"576cb4cb.446f2c","type":"debug","z":"86c72ff3.5f4c4","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"payload","targetType":"msg","statusVal":"","statusType":"auto","x":890,"y":600,"wires":[]}]

The setup on Slack...

The first URL in setup is an online service that actually reacts to the Webhook.

The thing is when posting towards my NodeRed env. from Postman that resides on "outside/internet" against my own domain the http-in reacts to the POST

Thanks!

If you send to http in GET from your mobile, connect to mobile internet, from a browser. does it connect and respond?

Does Slack have a log or response message?
Is Slack actually sending POST, may be PUT or other.
Try with rester POST from inside your local network

Hmmm... I got it working!!!

I actually just restarted my NodeRed service and all of a sudden it started to respond from Slack!!

Thanks so much for you're help!
It's always good to interact, just for getting all the questions I didn't come up with on my own :slight_smile:

I can't understad though what might have been "wrong" in NodeRed before the service restart.....

Thanks again!

Kjell

maybe slack need time to set up webhook.