Webhook in issue


I am trying to ger some webhooks into NodeRed but I am having an issue at the complete start;
I can get the webhook onto webhook.site without a problem.
When I try to get it in NodeRed I get an error "Error: missing nodes property" three times; according to the documentation this is because the sender didn't get the connection to server. (it tries to send it 3 times).

I tried with function and switch node to send message 200 back but with no success...

Here is what documentation says:

The block expects the receiver to respond to each POST message with a 200 (OK) HTTP status code. If a TCP connection couldn't be established while sending the output, the block will attempt to do it again up to 2 times immediately after the failure. If a TCP connection has been established, but the receiver didn't respond properly, the block will resend the message every 10 seconds up to 2 times. Then the message is discarded.

Edit; I tried to connect to the server with curl from Poweshell but I also can't connect...

The http-in node serves get/post requests, a webhook may be more specific in its communication.

Can you post an example flow what you are trying to do ? use the:

and post your code there.

I just found owt; it was a stupid mistake...
I was publishing to http//ip.addr/flow
and it looks that Nodered is already handling this path somehow and it doesn't allow connecting...

One of the admin routes. Set httpNodeRoot in settings.js if you want to avoid clashes. Or change the admin root alternatively.