When I restart Node-red, or refresh the browser, MQTT broker & nodes show error

This has started occurring recently, possibly related to installing the beta.

Node-red 3.1.0-beta3, npm 16.19.1 is running on a Raspberry Pi Zero 2.
Mosquitto 1.5.7 runs on another Pi in the same network.

When I restart Node-red the MQTT nodes show the red triangle. After moving a node to mark the flow dirty, attempting to deploy gives "some nodes are not properly configured"

MQTT messages do apparently still flow through the nodes.

To resolve it I have to edit any one MQTT node, click on the pencil and update. This also marks the flow dirty.

I am not hopeful, but you could try clearing the browser cache (from the menus) and reload the page.

It doesn't resolve it but clearing the cache and reloading the page triggers it.

This is Firefox, on a PC not the NR machine. I have it set to clear everything when the browser exits.

Is the node config stored in the browser? in cookies?
After clearing, reloading, fix and deploying I don't seem to have any cookies.

Not if you have cleared the cache and refreshed the page.

What is in the node red startup log?

Welcome to Node-RED

9 Jun 16:49:44 - [info] Node-RED version: v3.1.0-beta.3
9 Jun 16:49:44 - [info] Node.js  version: v16.19.1
9 Jun 16:49:44 - [info] Linux 6.1.19-v8+ arm64 LE
9 Jun 16:49:46 - [info] Loading palette nodes
9 Jun 16:49:51 - [info] Dashboard version 3.5.0 started at /ui
9 Jun 16:49:54 - [info] Settings file  : /home/pi/.node-red/settings.js
9 Jun 16:49:54 - [info] Context store  : 'default' [module=memory]
9 Jun 16:49:54 - [info] User directory : /home/pi/.node-red
9 Jun 16:49:54 - [warn] Projects disabled : editorTheme.projects.enabled=false
9 Jun 16:49:54 - [info] Flows file     : /home/pi/.node-red/flows.json
9 Jun 16:49:54 - [info] Server now running at
9 Jun 16:49:54 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

9 Jun 16:49:55 - [info] Starting flows
9 Jun 16:49:56 - [info] Started flows
9 Jun 16:49:56 - [warn] [function:function 4] on start
9 Jun 16:49:57 - [info] [mqtt-broker:6acd88c889789c5c] Connected to broker: mqtt://

No error is shown when I reload the editor and so trigger the red triangles.

Have you got any unused mqtt config nodes?

No, none.

(I think) I deleted and recreated the config ID, still the same.

Clutching at straws here. Have you checked the browser console?

Otherwise, maybe downgrade node red again and see what happens. You may have to remove a spurious config node after downgrade.

@jbudd if you can recreate this in a repeatable manor, could you please raise an issue on the Node-RED repository?

Please include the stepwise instructions.

Thank you.

I have tried a new OS installation, installing NR, installing the beta ...#

The issue has not (so far) manifested.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

I have re-opened this following discussions at 🎉 Node-RED 3.1.0-beta.4 released - #33 by Colin

I have also edited the title to indicate the problem re-appears after refreshing the browser.

I have checked the browser developer console and no errors are shown.
If anyone has any ideas on how to diagnose this please say.

See 🎉 Node-RED 3.1.0-beta.4 released - #44 by Colin

Closing this again.