When installing dependency node-red-dashboard 2.21.0 cannot reconnect to node-red

Hello,
i have a weird issue. i use a raspberry pi debian sw.
I clone a project from bitbucket and install the dependecies needed.
when i install the . "node-red-dashboard 2.21.0 " dependency node red crashes and i cannot reconnect to it.
the other two dependecies are "contrib-signalcore" and "node-rbe".
Problem is that without the installed dep my flows cannot run.
Has anyone else encountered this and found a way around it

Welcome to the forum

Please stop node red and start it again in a terminal and post the full output here.

Good morning Colin, thanks for the quick reply

i am uploading some snapshots that may assist you. As you can see after installing the dashboard dependecies node red immediately crashes.


so before installing the dashboard dependency i can access both the ui and the flows. obviously i cannot deploy them since there are flows without the needed dependency, the moment i install it it goes haywire

The signalcore node is crashing node red (which can be seen from the output you posted). There appears to be absolutely no information about what it does at node-red-contrib-signalrcore (node) - Node-RED so it is difficult to help. How do you know what to do with it?

it enables signal transmission to a server i set up.
attached how it should be normally.
if i dont enable the contrib signalcore dependency i cant establish a connection with my server.
But the problems do not start with this dependency it's working fine.
even if the only dependency i download is the dashboard, node red crashes.
node red signalr

Show us the startup log without that node in use so we can see what else is causing it to crash. This time please copy/paste the full startup log here, not a screenshot.

This is simply all the flows imported from bitbucket.

Welcome to Node-RED

13 Jul 08:32:06 - [info] Node-RED version: v2.2.2
13 Jul 08:32:06 - [info] Node.js version: v16.16.0
13 Jul 08:32:06 - [info] Linux 5.10.17-v7+ arm LE
13 Jul 08:32:08 - [info] Loading palette nodes
13 Jul 08:32:11 - [info] Settings file : /home/pi/.node-red/settings.js
13 Jul 08:32:11 - [info] HTTP Static : /home/pi/.node-red/projects/ergoparking-terminal
13 Jul 08:32:11 - [info] Context store : 'default' [module=memory]
13 Jul 08:32:11 - [info] User directory : /home/pi/.node-red
13 Jul 08:32:11 - [info] Projects directory: /home/pi/.node-red/projects
13 Jul 08:32:12 - [error] Uncaught Exception:
13 Jul 08:32:12 - [error] Error: listen EADDRINUSE: address already in use 0.0.0.0:1880
at Server.setupListenHandle [as _listen2] (node:net:1372:16)
at listenInCluster (node:net:1420:12)
at doListen (node:net:1559:7)
at processTicksAndRejections (node:internal/process/task_queues:84:21)

this is after the dependencies

13 Jul 08:36:28 - [info] Node-RED version: v2.2.2
13 Jul 08:36:28 - [info] Node.js version: v16.16.0
13 Jul 08:36:28 - [info] Linux 5.10.17-v7+ arm LE
13 Jul 08:36:30 - [info] Loading palette nodes
13 Jul 08:36:34 - [info] Dashboard version 2.21.0 started at /ui
13 Jul 08:36:34 - [warn] ------------------------------------------------------
13 Jul 08:36:34 - [warn] [node-red-node-rbe/rbe] 'rbe' already registered by module node-red
13 Jul 08:36:34 - [warn] ------------------------------------------------------
13 Jul 08:36:34 - [info] Settings file : /home/pi/.node-red/settings.js
13 Jul 08:36:34 - [info] HTTP Static : /home/pi/.node-red/projects/ergoparking-terminal
13 Jul 08:36:34 - [info] Context store : 'default' [module=memory]
13 Jul 08:36:34 - [info] User directory : /home/pi/.node-red
13 Jul 08:36:34 - [info] Projects directory: /home/pi/.node-red/projects
13 Jul 08:36:34 - [info] Server now running at http://127.0.0.1:1880/
13 Jul 08:36:34 - [info] Active project : ergoparking-terminal
13 Jul 08:36:34 - [info] Flows file : /home/pi/.node-red/projects/ergoparking-terminal/flow.json
13 Jul 08:36:35 - [info] Starting flows
13 Jul 08:36:35 - [warn] [rpi-gpio in:7cc8ea63.7277b4] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio out:39473253.27d67e] GPIO pin already set as type: input
13 Jul 08:36:35 - [warn] [rpi-gpio out:39473253.27d67e] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio in:2d435870.4a6118] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio out:c4c1af15.28ed6] GPIO pin already set as type: input
13 Jul 08:36:35 - [warn] [rpi-gpio out:c4c1af15.28ed6] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio in:3db899ba.f9af56] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio in:dc62b2ea.9b2fd] Invalid GPIO pin: undefined
13 Jul 08:36:35 - [warn] [rpi-gpio in:f8d100f4.143d] Invalid GPIO pin: undefined
13 Jul 08:36:36 - [warn] [rpi-gpio out:89ab0860.5ad878] GPIO pin already set as type: input
13 Jul 08:36:36 - [warn] [rpi-gpio out:89ab0860.5ad878] Invalid GPIO pin: undefined
13 Jul 08:36:36 - [warn] [rpi-gpio out:6faad31a.34757c] GPIO pin already set as type: input
13 Jul 08:36:36 - [warn] [rpi-gpio out:6faad31a.34757c] Invalid GPIO pin: undefined
13 Jul 08:36:36 - [warn] [rpi-gpio in:7b1e79e1.316af8] Invalid GPIO pin: undefined
13 Jul 08:36:36 - [warn] [rpi-gpio in:9543c7f4.9726f8] Invalid GPIO pin: undefined
13 Jul 08:36:36 - [info] Started flows
13 Jul 08:36:37 - [info] [serialconfig:bcda50ef.ef107] serial port /dev/ttyACM0 opened at 9600 baud 8N1
13 Jul 08:36:37 - [red] Uncaught Exception:
13 Jul 08:36:37 - [error] Error: Cannot send data if the connection is not in the 'Connected' State.
at HttpConnection.send (/home/pi/.node-red/node_modules/@microsoft/signalr/dist/cjs/HttpConnection.js:132:35)
at HubConnection.sendMessage (/home/pi/.node-red/node_modules/@microsoft/signalr/dist/cjs/HubConnection.js:353:32)
at HubConnection.sendWithProtocol (/home/pi/.node-red/node_modules/@microsoft/signalr/dist/cjs/HubConnection.js:360:21)
at HubConnection.send (/home/pi/.node-red/node_modules/@microsoft/signalr/dist/cjs/HubConnection.js:377:32)
at SignalROutNode._inputCallback (/home/pi/.node-red/node_modules/node-red-contrib-signalrcore/signalr-client/node.js:296:35)
at /usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/Node.js:210:26
at Object.trigger (/usr/lib/node_modules/node-red/node_modules/@node-red/util/lib/hooks.js:166:13)
at SignalROutNode.Node._emitInput (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/Node.js:202:11)
at SignalROutNode.Node.emit (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/Node.js:186:25) at SignalROutNode.Node.receive (/usr/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/nodes/Node.js:485:10)

Why are you using version 2.21.0 of the dashboard? Do you know the latest version is 3.1.7?

Also, did you read the errors? It is still crashing due to the signalr node. You have not uninstalled it.

The reason for the port in use error is that you tried to start node red without stopping it first, so it tried to start a second instance of node red

In fact you probably don't need to uninstall it. Provided you have removed all nodes of that type from the flow, then start in safe mode, go to Configuration Nodes in the dropdown menu and click Unused at the top. That will show you all unused configuration nodes. Select them and use the Delete key to delete them. Then deploy.

Hi Colin,
Yes you were correct the signlaR inputs and outputs were crashing NR. I deleted them and the interface opens correctly now.
the downside is i do not have communication with my server now which is obviously normal.
How can i know why these 3 signalR nodes where crashing my NR and what can i do to fix them?

[2022-07-25T09:54:49.447Z] Error: Failed to complete negotiation with the server: Error: connect EHOSTUNREACH 192.168.1.60:5000
[2022-07-25T09:54:49.448Z] Error: Failed to start the connection: Error: connect EHOSTUNREACH 192.168.1.60:5000

I think you will need to ask the author of the node, or examine the code and work it out yourself.

indeed.
thanks a lot Colin.
all the best

Hi again Colin,
when i run an npm audit on my project folder i get the warning below.
So indeed there is an issue with the dashboard dependecie.

npm audit report

node-red-dashboard <2.26.2
Severity: high
Path traversal in Node-RED-Dashboard - Path traversal in Node-RED-Dashboard · CVE-2021-3223 · GitHub Advisory Database · GitHub
fix available via npm audit fix --force
Will install node-red-dashboard@2.30.0, which is outside the stated dependency range
node_modules/node-red-dashboard

1 high severity vulnerability

To address all issues, run:
npm audit fix --force

can someone explain to me what this means. i run npm audit fix --force command on the project folder where the json package is but i always get the same result.

any advide?
thanks in advance

maybe install latest version of dashboard (3.1.7) if you are able ?

That is almost always a bad idea, as it may install versions of modules later than those the node was tested with.

1 Like