2.0.6 shows different node errors in different languages

Not a huge issue, but..... Since updating to 2.0.6 I am finding different nodes throw different errors in different languages (other than my PC's native English).
I have seen either Chinese or Japanese characters (I'm not sure which - sorry) and then this one tonight.


Yes, I know, I should fix the errors, but in this case, it's in a CSV node and only happens randomly, I am not sure how to fix the node.

My question is, how do I tell Node-RED to use my PC's default language?
(Or is this a question for the NodeJS forums? Currently on v16.3.0).


Which CSV node are you using the base css node or a contrib one?

I find 3 (well two since two are from the same author. The name was changed from ...-cvs... to ...-csv...) that show up in the flow tab. The newest was updated in July of 2017.

Its the core node.
It shows as version 2.0.6.

Is anything else showing stuff in the wrong language or just the csv node errors?

You say it is intermittent, do you mean the same error message on the same node appears in different languages in an apparently random way?

Is there anything else odd about your system? What OS are you running?

Does the node-red log show anything unusual? You could post the startup log for us to look at.

Is the system log showing anything odd?
Have you tried a reboot?

I am pretty sure that another node is throwing the hieroglyphic errors.

By intermittent I mean that sometimes the node returns the error in English, other times not.

Very stock/clean system. Win 10 Home. nodeJS, Node-RED and Sqlite.

Did not yet cross check the debug tab error with the log, thanks for the reminder to do that.

By system log, you mean the Windows OS logs? Also did not think to check there.
Yes, have had a few Windows update reboots since installing NR 2.0.6.

No, I meant the Linux system log, but I see that is not relevant :slight_smile:
I don't know about Windows but hopefully someone who does will have some suggestions.

This morning I got this in my debug tab:


Its from the same node - so safe to say, its the core CSV to JSON node that is throwing the incorrect language errors.
There is nothing in the CMD window that Node-RED runs in, ie, the Windows Node-RED log.

This is from a HTTP Request Node. (Again, a core node).
So its not just the one node throwing these errors.


Just happen to notice this as well.....

Add the core email node to the list:


Bizarre, I can't seem to reproduce this, mind sharing an example flow?

My flows would not make sense or function in isolation, and I am sure that its not the flow generating the different languages.

Even just an example payload may help.

@thebaldgeek good news - I've just had it happen to me, and I think I know why.

Don't have a fix yet, but recreating it (even accidentally) is usually half the battle.

1 Like

Let me know if I need to stop reporting these... but two new ones today.

No need to keep reporting. The issue has been fixed and will be in the next release.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.