3.0.4 will not be installed

Node-red 0.20.7
Hi there,
I'm running node red on realKNX Server (raspi) in my KNX Home. Till last update everything worked fine but now after trying updating to dashboard 3.0.4 this will not be installed correct and after the second try updating it installs the 2.15.5. That works fine but with a programmed reset every night the dasboard try automatic to update to 3.0.4 and this ends with the complete node and all ui not being installed.
Sorry if I'm not explaining or understanding this properly, I'm a beginner. Is there a way to turn off the automatic update or am I doing something wrong?

Thanks for help

Just restarting Node-RED should not cause any installed nodes to be upgraded. Something else must be going on here.

The only way this could happen that I can think of is if Node-RED is setup to install missing nodes at startup, but it will only do this if there is no userDir persistence and a storage modules that is keeping the settings object elsewhere. But that wouldn't explain why it's jumping from 2.15.5 all the way to 3.0.4 since there have been a lot of releases in between.

Without a lot more information it's going to be really hard to say any more, but I'm going to guess that the NodeJS version is also equally old and probably why the 3.0.4 is not working.

Hi hardillb,

thx for your help.
At least the manufaturer of the realKNX server helped me. Problem was that my running node red was not up to date on 1.26. Now it worked.
Why it always falls back to 2.15.5... don't know.

So thanks again and have a niche WE


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.