502: Bad Gateway

Had a brief (like a second) power outage last night. I can't get back into NR from Home Assistant because I'm getting a 502: Bad Gateway error. Tried restoring HA from yesterday, but that doesn't help.

Running HA and NR on an Odroid N2+.

I tried removing the folder "follow-redirects" and restarted NR, but I still get the 502, but with a different folder name in the error log.

This is the error log.

patching file nodes/ui_base.html
Hunk #1 succeeded at 1162 (offset 631 lines).
npm ERR! code ENOTEMPTY
npm ERR! syscall rename
npm ERR! path /config/node-red/node_modules/follow-redirects
npm ERR! dest /config/node-red/node_modules/.follow-redirects-SJVnQEvE
npm ERR! errno -39
npm ERR! ENOTEMPTY: directory not empty, rename '/config/node-red/node_modules/follow-redirects' -> '/config/node-red/node_modules/.follow-redirects-SJVnQEvE'
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2022-06-01T06_55_04_259Z-debug.log
[08:08:31] FATAL: Failed un-installing conflicting packages
[cont-init.d] node-red.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] 99-message.sh: executing...

Oops! Something went wrong.
We are so sorry, but something went terribly wrong when
starting or running this add-on.
Be sure to check the log above, line by line, for hints.

Any help gratefully received because my house is currently dead.

That looks to me like a corrupted disk. Probably safest to restore from backup.