Alexa-remote2 On HA, on a Pi4 what do I enter for the File Path

Hi, very new to Node-Red trying to set up node-red-contrib-alexa-remote2-applestrudel.

When I deploy I always have to go to my browser, the authentication is not being save.

In my path I have "/usr/share/hassio/homeassistant/node-red" (got from another forum)

it also said I need to add this in the "config /config/node-red/amazon.txt" but no idea where to put this.

Can anybody advise me.

Many thanks, Regards, Dave

I used to just have cookie.txt, this would save in the home folder, as it is taken a relative path. You couild also use the absolute path from root.

I do not set a file path any longer, or auto init and use the init node and save the resulting cookie to a flow context and load the cookie from flow context cookie in the inject.
e.g.

[{"id":"e63c03b3.745b48","type":"inject","z":"d629013b.18a518","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"86400","crontab":"","once":true,"onceDelay":0.1,"topic":"","payload":"alexa","payloadType":"flow","x":100,"y":1460,"wires":[["89e02d64.da77c8"]]},{"id":"89e02d64.da77c8","type":"alexa-remote-init","z":"d629013b.18a518","name":"","account":"c8738129.d902c","option":"initialise","x":290,"y":1460,"wires":[["fc0183e2.5e7c2"]]},{"id":"fc0183e2.5e7c2","type":"change","z":"d629013b.18a518","name":"","rules":[{"t":"set","p":"alexa","pt":"flow","to":"payload","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":490,"y":1460,"wires":[["421c02e9.68fdec"]]},{"id":"c8738129.d902c","type":"alexa-remote-account","name":"alexa remote 2","authMethod":"proxy","proxyOwnIp":"localhost","proxyPort":"3456","cookieFile":"","refreshInterval":"14","alexaServiceHost":"layla.amazon.co.uk","amazonPage":"amazon.co.uk","acceptLanguage":"en-GB","userAgent":"","useWsMqtt":"on","autoInit":"off"}]
1 Like

This solution is bloody brilliant. I've been having issues with Timeouts and the node deciding I was no longer initialized. No issues after employing this method. Thanks for this!