Help saving cookie with alexa-remote2-applestrudel

I'm using node-red-contrib-alexa-remote2-applestrudel with node-red on windows 11 and for the life of me I cant figure out how to save the cookie.

Any tips?

I use this flow with these setting, using proxy method, once you sign in with proxy the cookie is saved to context. You need to enable persistant context in your setting.js file Working with context : Node-RED

[{"id":"48d034130f262ec8","type":"inject","z":"b779de97.b1b46","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"86400","crontab":"","once":true,"onceDelay":0.1,"topic":"","payload":"#:(file)::alexa","payloadType":"flow","x":190,"y":2060,"wires":[["f78696691771c3ee"]]},{"id":"f78696691771c3ee","type":"alexa-remote-init","z":"b779de97.b1b46","name":"","account":"c8738129.d902c","option":"initialise","x":380,"y":2060,"wires":[["3b6342b82af27c5f"]]},{"id":"3b6342b82af27c5f","type":"change","z":"b779de97.b1b46","name":"","rules":[{"t":"set","p":"#:(file)::alexa","pt":"flow","to":"payload","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":580,"y":2060,"wires":[[]]},{"id":"c8738129.d902c","type":"alexa-remote-account","name":"alexa remote 2","authMethod":"proxy","proxyOwnIp":"localhost","proxyPort":"3456","cookieFile":"","refreshInterval":"14","alexaServiceHost":"","amazonPage":"","acceptLanguage":"en-GB","onKeywordInLanguage":"","userAgent":"","useWsMqtt":"on","autoInit":"off"}]

I think the issue is that the Amazon login page has gone, so you cannot sign in ?

I can, what page are you missing?

"" no longer has a login option ?

If you sign in at, you can export the cookie and then use that.

Still works for me as well - just installed it on a new (Pi) instance and I got the same page as @E1cid

What did you set in the service host of alexa config node ?

1 Like

I notice @E1cid is using "layla" not "alexa" as per instructions for UK

I was just speculating as to the OPs problem, as I'm sure that the last time I got the open xx.xx.xx.xx:3456 or whatever it is I didn't see a login option.

However I'm not about to risk breaking it again as its been working OK since the last outage :wink:

Have been for 3 plus years with no issues.

But that would not affect the proxy sign in either.

1 Like

Wealth of information here guys, thank you..

I haven't been able to get to that page for months. It takes me to:

I've tried every service host and can't get it to the old sign in page for anything. Any tips?

This is the issue I have. Since I can't sign it there is no cookie.

What is that page, your question is very vague.
what url are you putting in address bar. Need more concise info.

P.S. please start your own topic with the info required to help you.
Hijacking another's topic is bad etiquette.

Idea - make sure your not logged into amazon in your browser -e.g logout - worth trying :slight_smile:

1 Like

Amazing! I would have never thought of trying that. I had done everything else I could think of including a full rebuild of my home assistant. Today I tried again on a private browser, and it worked! Thank you

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.