Alexa save cookie to context

@E1cid I have been using your flow for a while, but lately it's been wanting me to login to the amazon to get the cookie. Then today all of sudden it is giving me a JSON error. I have restarted, made sure it is saving the flow to filestorage context and not memory. Any ideas what else I could check?

image

[{"id":"e63c03b3.745b48","type":"inject","z":"d629013b.18a518","name":"","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"86400","crontab":"","once":true,"onceDelay":0.1,"topic":"","payload":"alexa","payloadType":"flow","x":100,"y":1460,"wires":[["89e02d64.da77c8"]]},{"id":"89e02d64.da77c8","type":"alexa-remote-init","z":"d629013b.18a518","name":"","account":"c8738129.d902c","option":"initialise","x":290,"y":1460,"wires":[["fc0183e2.5e7c2"]]},{"id":"fc0183e2.5e7c2","type":"change","z":"d629013b.18a518","name":"","rules":[{"t":"set","p":"alexa","pt":"flow","to":"payload","tot":"msg"}],"action":"","property":"","from":"","to":"","reg":false,"x":490,"y":1460,"wires":[["421c02e9.68fdec"]]},{"id":"c8738129.d902c","type":"alexa-remote-account","name":"alexa remote 2","authMethod":"proxy","proxyOwnIp":"localhost","proxyPort":"3456","cookieFile":"","refreshInterval":"14","alexaServiceHost":"layla.amazon.co.uk","amazonPage":"amazon.co.uk","acceptLanguage":"en-GB","userAgent":"","useWsMqtt":"on","autoInit":"off"}]

What remote2 node are you using?
I suggest applestrudell, as i have had no issues with it.

I'm using node-red-contrib-alexa-remote2-applestrudel. Is this the same?

Here is my flow:

[
    {
        "id": "0d8788030616ce15",
        "type": "tab",
        "label": "Flow 2",
        "disabled": false,
        "info": "",
        "env": []
    },
    {
        "id": "e63c03b3.745b48",
        "type": "inject",
        "z": "0d8788030616ce15",
        "name": "",
        "props": [
            {
                "p": "payload"
            },
            {
                "p": "topic",
                "vt": "str"
            }
        ],
        "repeat": "86400",
        "crontab": "",
        "once": true,
        "onceDelay": 0.1,
        "topic": "",
        "payload": "alexa",
        "payloadType": "flow",
        "x": 330,
        "y": 200,
        "wires": [
            [
                "89e02d64.da77c8"
            ]
        ]
    },
    {
        "id": "fc0183e2.5e7c2",
        "type": "change",
        "z": "0d8788030616ce15",
        "name": "",
        "rules": [
            {
                "t": "set",
                "p": "#:(file)::alexa",
                "pt": "flow",
                "to": "payload",
                "tot": "msg"
            }
        ],
        "action": "",
        "property": "",
        "from": "",
        "to": "",
        "reg": false,
        "x": 720,
        "y": 200,
        "wires": [
            []
        ]
    },
    {
        "id": "89e02d64.da77c8",
        "type": "alexa-remote-init",
        "z": "0d8788030616ce15",
        "name": "",
        "account": "247f7a30d23d339b",
        "option": "initialise",
        "x": 520,
        "y": 200,
        "wires": [
            [
                "fc0183e2.5e7c2"
            ]
        ]
    },
    {
        "id": "247f7a30d23d339b",
        "type": "alexa-remote-account",
        "name": "",
        "authMethod": "proxy",
        "proxyOwnIp": "192.168.1.155",
        "proxyPort": "3456",
        "cookieFile": "",
        "refreshInterval": "14",
        "alexaServiceHost": "pitangui.amazon.com",
        "amazonPage": "amazon.com",
        "acceptLanguage": "en-US",
        "onKeywordInLanguage": "on",
        "userAgent": "",
        "useWsMqtt": "on",
        "autoInit": "off",
        "credentials": {}
    }
]

I also set it to store to the local file system.

image

Is it reading from file in the inject node?
Yes thats correct remote2 node.
Have you tried deleting the flow.alexa context storage?
Also try deleting the remote2 config and starting fresh,

It was not reading from file in the inject node and I updated that, but still the same error. How do you delete the flow.alexa context storage? I'll also try deleting remote2 this weekend.

in the sidebar, select the context tab. There you can see all context and delete context variables.

Just delete the config where you set proxy login details, not the remote2 nodes. You can access that in the sidebar to, under config tab.

@E1cid not sure what happened, but it seems to have resolved itself. Thank you again for your help!