Amqp node is not getting installed properly


I am trying to install amqp node for nodered.
I am using this command in my windows command prompt: npm install -g node-red-contrib-amqp
I am getting this error:
npm WARN notsup Unsupported engine for amqplib@0.4.2: wanted: {"node":">=0.8 <6 || ^6"} (current: {"node":"12.18.1","npm":"6.14.5"})
npm WARN notsup Not compatible with your version of node/npm: amqplib@0.4.2

Can anyone please suggest what to do?

Thanks in advance

You can't go back to nodejs 6, 8.x is currently the oldest currently supported by node red. I see there is already an issue for this on the github page, but the project does not seem to be getting much love at the moment.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.