[Announce] node-red-contrib-ui-level

though the idea of the segments is to show how close you are to that region of operation. If it's a single colour you have no idea where you are on that scale... but I guess it's a choice.

How about a select " show " [ multiple segments ] / [ single colour bar ]

PS - What is Schema in the current settings ? I have no idea what this means in the context. How do I pass in a schema ?

I intend to build a dashboard page that shows the battery status of a whole bunch of devices. It would take all but a quick glance to see if a battery needs replacing :slight_smile:

1 Like

Will be implemented on next version. Feature behavior stays :slight_smile:

1 Like

Slight diversion of current topic - but setting range from 0 to -100 doesn't work ...

Diversion ended up with improved widget in version 0.0.19 :slight_smile: Thank you!

1 Like

Hi, new in this forum but I cant find in dr.google any answer about it.
If I use the pair modus with channels a and b how do I give the load/value to the channels....
can sombody give me an example...
thanks :slight_smile:

Welcome to forum.
The info page says - For Pair Horizontal layout the msg.payload is expected to be an array
If you are using function node then it should look something like this:
msg.payload = [15,20]

thanks for the fast replay :+1:

Hi. I cannot get the bar to show anything. Anyone else who has this issue?

Node Red v1.0.4
node-red-contrib-ui-level v0.1.26
Chrome browser, Win10


Can you add a debug node in your flow just before the ui-level node and post the results here, so we can see what you are feeding into the node.

Like this?

The weird part is that the number is correct, it is only the bar

I've also tried injecting msg.payload : 54 directlyg with an inject-node

About your setup, do you run Node_RED locally, or cloud or using docker?
Can you see errors in browser dev tools console?

I run it locally, as an add-on to Hassio (Ubuntu + Docker)

Console log from Chrome. It is not working on my Android phone either

Complex setups which I can't to check ...
There has been similar issues with solution. Try if it helps.

Do you think it has to do with gsap is not defined?

And 404 (Not Found)

@hotNipi - (regarding the linked solution) Yes, Theres is no manifest to delete in chrome.
I've tried Firefox. Same problem. gsap not defined

@hotNipi ok, thank you so much for taking a look at it

(Sorry I have to reply here - new user limit on replys)

Too bad. I can't say much about why. This problem comes with your setup, which I can't build for myself thus can't test.

Are you sure?
In your chrome browser, enter chrome://appcache-internals/# in the address bar, and enter.
Do you see the AppCache manifest? if so click 'Remove item' against the nodered item, then go back to your dashboard and press F5 to refresh.

Edit - See following post.

No it does actually nothing. I found the issue. Wait for ui_level update.

1 Like

Version update available.

It is working now. Gsap loads, and all is awesome :slight_smile:

Thank you for update