Anyone having issues with SmartLife Air nodes?

For some reason, I am not getting output from the SmartLife Air device-node node anymore. I am still running 1.1.3 of NR, NPM, NR, or Node versions have changed since the flow was working as expected.

Also, found this on GitHub, there might be an issue with SmartLife Air nodes working with NR 1.2? Just FYI. https://github.com/razorRun/node-red-contrib-smartlifeair/issues/14

I raised the 1.2 issue

After it failed for me, I installed it into another instance to turn a bulb off/on and that worked fine - just tried it again and still working

In my case, I still am not seeing the dev-node node return correct output. This morning I got nothing back, which implied something was happening at the SmartLife Air side. The state changed, the device turned on/off. But the output never happened. After, about 2 hours, started to randomly get output ONLY after I did a deploy of a changed flow... which is really odd, implies that the node initialization sequence is flushing a buffer or something? But the device state reported in the output was wrong, if I turned on the device, output reported off, and if I turned off device, would report on. Will be interesting what the guys at SmartLife Air come back with. I even checked my local network, WiFi, etc. Nothing seems a miss. Until now SmartLife Air nodes have been rock solid and consistent, much better than any other smart nodes I have used before.

That is the same issue as reported on the later github issue.

I don't monitor the outputs-I'll check later after tea

Cool. Thanks. If there is anything I can do to help figure what the heck this is, just let me know.

On my test instance - like you - I'm getting nothing from the output of the node

Thanks... that confirms that it is not something I did to break something. My flow has been working for weeks, now it is not.

Something change? Seems like I am getting output now? Still testing. Just thought of something... it there a payload value I can sent to the device-node node that will just cause it to generate the state of the device as output? I tried an empty payload, but that did not seem to generate any output. Of course sending true or false to the node if it changes the switch state or example generates output, but at times would like to just query the device for its configuration or state with no change needed.

Well, the output is inconsistent, for a while early this morning it seemed to be working, but as I continued to test, it became clear the issue still persists.

JFI The issue I reported has gone away after I upgraded to 1.2.2

And my nodes are outputting as well

(I hadn't configured my test instance properly so I think that was why that wasn't outputting messages because as soon as I set it to output everything as JSON - it worked - so treat my earlier report of not working as very suspect)

I

So far this morning, the issue is gone, and I did not change versions of anything... to keep the environment consistent. So there may have been an update or fix on the back-end?