Azure IoT Hub stops receiving data

Greetings everyone,

I've been trying to use the azure-iot-hub ( node to aquire data from some devices registered on the platform, and for the most of the time, it works well. Nevertheless, from time to time it just stops receiving messages, even if it still registers on Azure.

Because this error is intermitent, it's being really tough to realize what unusual event is happening for the node to stop receiving data and never really recovers, just just doing that when I realize the problem and redeploy the azure-iot-hub node.

They both are configured the same way and come from different IoT Hubs, but it's just one node that don't receive data at a time, usually the same one.


I have the same problem. My remote sensor sends data every minute and these are received by the node Azure IoT Hub Receiver, but the nodo goes into error after 2 or 4 hours of operation. If I re-deploy the Flow the node goes back to work and receives telemetry data.

Did you find a solution?

I tried to isolate the nodes and it worked fine, for days even. But when I least expected, it stopped receiving telemetry data again for the same reason.

Still not sure what this issue may be, since I tried to use Event Hub as well and eventually it gave me a similar error: the broker was getting data, but not sending forward to my application.

The node doesn't asks directly for a SAS token, so even if it was a credential expiration problem, I wouldn't know how to solve it.


Hi Afew!,

I have not found the solution to the problem with azure-iot-hub.

I discarded this solution and created my own MQTT Broker in an Azure virtual machine where I installed Mosquitto.

Now I use the MQTT nodes and it works very well.