Call Service Node: Property: Area

New to Node Red. Creating first simple flow: motion to turn on light.

image

All good until I get to selecting "area" - the dropdown does not list Guest Bedroom - it does list all the other areas:

The "area" dropdown does not list my Guest Bedroom. And the Device dropdown does not list the guest bedroom light switch.

Everywhere I can "see" in HA, the area Guest Bedroom is identified and the Guest Bedroom light switch is listed as part of the Guest Bedroom area.

How do I correct this no listing for the guest bedroom area and hence the associated light switch?

Many thanks in advance for your help !!

As this is primarily an HA question you will probably get a better response on the HA forum as not many folk here use those nodes

@dceejay Many thanks - will do!!

@dceejay I am back. So far, some HA community folks think this might be a bug in Node Red. So I am back to maybe this is a Node Red issue.

So would ask for you to take another look as you have time?

Should I uninstall Node Red from HA and reinstall it?

I have looked at HA logs but can find no errors, warnings, etc.

Your help is appreciated.

What did they guys in the HA forum say to backup the claim this might be a node-red bug? The HA nodes are not written or maintained by core node-red developers so it seems quite unlikely this is a node-red issue.

Are there any errors in your browser's console when you change the dropdowns?

@Steve-Mcl The guidance suggested was - add in new areas, assigned/associte devices and cehcek Node Red. I added new "areas" in HA, but they do not appear in Node Red. This is what is leading folks.

On the "browser's console" errors, if I understand the question, no errors appear in an browsers.

Would uninstall/reinstall of Node Red help?

@Steve-Mcl One other thing, all my other areas appear in Node Red just fine. Only one has not appeared: Guest Bedroom. I tried renaming, deleting and creating a new are: Spare Bedroom. Spare Bedroom did not appear in Node Red.

Did you open the browsers console? (Usually F12 key)

The thing is: these "areas" are not created in node-red & the only possible way they can be presented to the node edit panel is via http or web socket or some means of browser to server communication. All of this is performed by the "node" which is written by the HA guys.

I know this as I am a maintainer of node-red & understand how these things are put together.

Moving forward, to get some cold hard evidence, I suggest you open your browser's devtools network tab, operate the dropdowns & look in the responses - somewhere in one of the http requests will be the data that populates these dropdown elements. I suspect that HA is not providing this info to the node-red node it there is a front-end bug in the ha nodes that prevent this entry being displayed.

Ps. Have you tried other browsers? Have you tried a hard refresh / cleared the browsers cache?

@Steve-Mcl Here is a screenshot of Chrome browser console:

I will admit - this console view is over my head. Many errors though. As I read the console view - errors are for Grammarly, there are warnings about Home Assistant not loading DevTools (which I do not know what that is), and appears (yes?) that Node Red is loading correctly - no errors.

My chrome browser is set to clear the cache each time it is closed. I however, manually cleared the browser cache. Restarted and took the following screen shot:

I have also tried Firefox, same results. I have rebooted the Odroid N2+ device hosting HA a couple of times, I have restarted HA several times - no joy. Nothing else is running on the Ordoid N2+ - only HA (and the addon integrations.)

devtools network tab? Is this what you are referring to:

Your guidance and counsel is appreciated.

@Steve-Mcl Well, in my troubleshooting - I did the following:

In HA, deleted Guest Bedroom Area. Created a new area: Spare Room. I completely uninstalled Node Red. Restarted HA and reinstalled Node Red. In the images below, you can see Spare Room is present. But upon further review, many rooms are not: Dinette, Dining Room, Entryway, Garage, Hall Bathroom, Hallway, Kitchen, and Office.

Is your guidance to pursue this issue from an HA aspect?

Standing by and thanks!

This definitely looks like HA is not providing the HA node with the necessary elements. Have you posted the same message with screenshots on the HA forum?

Yes - no response so far. I am going to post in a couple more areas within the HA community - better coverage.

Many thanks for your help, it is greatly appreciated.

One thing I've noticed from your earlier screenshot - you have A BOAT LOAD an unhealthy amount of browser plugins...

Many times I've seen is issues they were caused by a plug-in.

Have you tried a different browser? Have you tried incognito mode? Have you tried launching browser without any plugins loaded?

In Firefox, it was the initial opening (instance) when I tried it there - same result.

I will retry in Chrome with one instance open and then retry with no plugins.

Good advice....working....

@Steve-Mcl Great questions - so I started checking. After writing a long response with multiple graphics and I then deleted that e-mail.

Why: Because I posted this issue in another area with HA Forum (as we discussed) and rec'd an inquiry for me to check. THis caused me to change a parameter in Node-Red and whamo !!!.....many, many more areas showed up.

So, in Node-Red, a strange behavior? Depending on the "domain" you select in the "edit node" window, more area/rooms seem to load - or appear.

So - when I first selected the domain "light" in the "edit node" window, a set of areas/rooms are loaded (?) into Node-Red and presented. (but only those associated with that domain?)

When I change the domain to "switch" in the "edit node" window, and then select "area", a "new" or "added to" set of areas/rooms are loaded (?) / presented into Node-Red - or becomes visible (I am not sure how Node-Red loads and presents data from HA.).

Now, when I change domains back to "light", the areas loaded from the "switch" stayed. So Node-Red does not dynamically display only those entities associated with a domain. Does that make sense? It seems you need to select different domains to get all areas loaded or to be presented in Node-Red.

However, being a newbie, I am not sure - do you need to select an "area"? and if you do - does it have to have the entity in that area? Maybe more learning.

So - I think Node-Red is working, HA is working, (both great things in my world!!!). I simply need to learn Node-Red and understand its ...quirks? Maybe not a quirk. Maybe it is showing what I asked for - I just did not understand. Always humbling. But learning all the same - a good thing.

Many thanks for your all your help (!!) - it got me on the right track!! :grinning:

Any advice on the "area" concept for understanding would be appreciated.

Many Thanks to you SteveMcl !!