Can not access editor from another computer

Hi there,

My node-red is installed in a ubuntu machine(ip: and it is running normal, but when i want to access the editor from another computer by browser(, it shows error: "This site can’t be reached took too long to respond", this happen after power outage. I can ping from the computer to

Have you ever accessed that computer before? Did you reboot everything , computers, routers any access points?

Thanks gerry.
yes, i can access the editor from the computer before and I also rebooted the computer,router and node-red server.

Assuming you can see the editor on the local machine it has to be a network latency problem. You can ping but loading screens is more traffic intensive. Hence. The timeout you are seeing. If you can hardwire the two together and it works then your wifi is honked up. From there it gets fuzzy fast as to what you should do next.

My computers are connected by cable not WIFI and the ubuntu server doesn't have any browsers.
Do you think it is port 1880 is blocked issue? Sorry no idea how to fix the network issue.

So is node red running on the server?

I mean if you go to the command prompt on the sever and do node red stop and start does it reply?

yes, the node red is running and no error in the server.

How did you determine node red is running?

I ran node-red from the command line and check the out message

Sorry but this is where I tap out. Out of suggestions.

Anyway, thank you so much for your help and time.

Stop node red and start it again in a terminal. Try to connect from the remote machine. Then copy/paste the full terminal output here please.

Hi Colin,
This is the output after I restarted node-red:

Welcome to Node-RED

12 Dec 16:18:22 - [info] Node-RED version: v2.0.5
12 Dec 16:18:22 - [info] Node.js  version: v12.22.5
12 Dec 16:18:22 - [info] Linux 4.15.0-163-generic x64 LE
12 Dec 16:18:22 - [info] Loading palette nodes
12 Dec 16:18:23 - [info] Settings file  : /home/delmar/.node-red/settings.js
12 Dec 16:18:23 - [info] Context store  : 'default' [module=memory]
12 Dec 16:18:23 - [info] User directory : /home/delmar/.node-red
12 Dec 16:18:23 - [warn] Projects disabled : editorTheme.projects.enabled=false
12 Dec 16:18:23 - [info] Flows file     : /home/delmar/.node-red/flows.json
12 Dec 16:18:23 - [info] Server now running at
12 Dec 16:18:23 - [warn] 

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

12 Dec 16:18:23 - [info] Starting flows
12 Dec 16:18:23 - [info] Started flows
12 Dec 16:18:23 - [info] [amqp-server:bb46899d.e73dd8] [AMQP] Connection status: connecting
12 Dec 16:18:23 - [info] [amqp-server:bb46899d.e73dd8] [AMQP] Connection status: connected
12 Dec 16:18:24 - [warn] [function:e5c1fa21.d837e8] [object Object]
12 Dec 16:18:24 - [warn] [function:e5c1fa21.d837e8] [object Object]

I don't know if it is a factor, but the early V2 node red versions did have sone problems. Is there a reason you are not using an up to date version? You can upgrade using the Debian/Ubuntu/Pi update script from the node red docs.

Thank you,

I used some nodes which are working on early node red versions. Maybe it is not node-red issue because I have another server which I can access remotely by browser with port 1880. Do you think it is network route issue?

Check whether node red is listening on port 1880 using one of the command line programs. Google for how to check for open ports. I always have to look it up.

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0*               LISTEN
tcp        0      0 *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0*               LISTEN
tcp        0      0*               LISTEN
tcp        0      0 *               LISTEN
tcp        0      0*               LISTEN
tcp        0      0*               LISTEN
tcp        0      0 *               LISTEN
tcp        0      0    *               LISTEN
tcp        0      0  *               LISTEN
tcp        0      0  *               LISTEN

So the port is accessible ok, that suggests that maybe it is a firewall in the machine running the browser.
Another check worth doing though. Check you can ping the server, then unplug the server's network connection and make sure the ping no longer works.

I can ping from the computer with browser to node-red server(


Pinging with 32 bytes of data:
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64
Reply from bytes=32 time<1ms TTL=64

Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms