Can’t connect NR to control Kodi?


I’ve tried a number of ways to connect to my Kodi installation but had no luck, I’ve tried the Kodi node (which just keeps showing reconnecting), I’ve also tried a tcp node (which shows connected but I can’t get that to work with a command), and I’ve also tried a websocket node, but no luck ?

I can access and control kodi via its web interface in a browser (as that’s enabled), but that’s it - any ideas anyone - does anyone have a working set up ?

I’m using v17.5 of kodi
Kodi web port shows up as 8189

As I continue to try things, I can get the following to work directly into a browser.{"jsonrpc":"2.0","id":"1","method":"GUI.ShowNotification","params":{"title":"Test Household","message":"Everything is great","displaytime":6000}}

Which seems to confirm the ip and port were correct within the other attempts, but no idea why I cant send these jsonrpcs directly via node Red

As I can get it to work via a http request node, using a function or template to do the json, I can only assume the issue is with connection via tcp and/or with the kodi node Red module..