Cannot collect any data from the aubobot

I'm currently connecting from node-red to Aubobot through TCP in node-red but node-red shows disconnected and connected frequently, and can't get any data out of the AUBO. I am able to ping AUBO IP from my computer and have checked the lan cable connection. I have also tried restarting node-red but the problem still persists. I would appreciate any help!
At first, I thought it was the error connecting to the PLC but I found out that this error is from the other flow, will it affect me from collecting data from the AUBOBOT?

(this is the IP and the port for my AUBOBOT)

(this is the error connecting to plc from, it is v1.3.5)

(this is the flow I try on the v1.3.5, but it shows the same result, the connection is unstable and when I debug there is no data shown)
the connection of the AUBO is very unstable for both versions, will this be the reason why no data is shown? I used v1.3.5 and v0.20.3 to try but the result is the same no data coming out and when I debug the node but there is nothing shown

this is the flow I make on the v0.20.3, the error at the side is from the other flow, v1.3.5.

I am not really sure you have this around the right way

Usually you would send a request (TCP/UDP) ) to the PLC and it would then send a response back - either direct to an IP address or on a broadcast address on a set port.

So in the case of my inverters which talk UDP - i send a UDP request to a specific IP address and Port (using the UDP out node) and wait for a response back - which is a UDP broadcast on a specific port from a Specific IP address.

I do not really understand how you have gotten this far with this complex a flow and not come across the problem/issue before now.

The way i would tackle this is as follows

  1. Disable all the current flows on this machine that talk to the Audobot and create a basic flow - that simply sends a request to the unit for a status update and see if you get a response.

If this works then you need to put this on (say) a 10 second loop and see if the packets continue to come in reliably.

Keep on reducing this loop time until you get down to 1 sec and you will then know if you have a throughput issue or some other problem

Once this is done report back and let us know

But as we can not duplicate your environment it is imperative that you simplify what you are doing as much as possible to enable us to understand what you are doing and try to help

Also you need to name your Debug nodes to make it easier to understand which ones are producing the messages and in your function nodes it would be a good idea to look up how to use node.status so you can provide some useful info underneath each function node

Finally a netowkr diagram or description would be nice - you are throwing around terms like PLC - which i assume is your S7 device ? and then Audobot - it would be nice to know where these reside etc


I'm not very sure how to create a basic flow so I try a
few ways but I still don't get anything and it shows an error: connect econmrefused.

For our network diagram, our robots are connected to two switches, whereby one switch is connected to a power plug and the other switch is connected to the tdce SICK and the tdce is connected to the internet.

something look this^
The PLC belongs to S7 device as the S7 device contains PLC software and hardware

OK this looks different - you are now using a http node where before you were using a TCP node on a different port.

Can you open a web browser from your machine and navigate to (which is what you are trying to get NR to do)

Econnrefused usually means that there is no webserver running on Port 80

Have you disabled all the other flows to make sure you are not having some form of port conflict from the NR box to the Audobot ?


the I have no idea where it comes from, before this I try to put in port 8899 but the same error came out. I only disable the flow for Aubobot.

does this mean that having the same port number? the port number of Aubo i got it from the robot manual.

OK so have you tried from a web browser as i suggested and see what response you get ?


yes, I did try. it shows "this site can't be reached"
I tied the, which is suppose to be correct, but it shows "didn't send any data"

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.