Error connecting to PLC: Error: connect EHOSTUNREACH

I'm currently connecting from node-red to Aubobot through TCP in node-red but node-red shows disconnected and connected frequently, and it shows an error connecting to PLC I have no idea what is this and how to solve it. Also, I can't get any data out of the AUBO. I am able to ping AUBO IP from my computer and have checked the lan cable connection. I have also tried restarting node-red but the problem still persists. I would appreciate any help!

Ok some basic network troubleshooting here

Can you SSH into the NR box ? If so do so and then perform a ping to the Aubobot

If you can ping and get responses then try and a Telent connection on the port that the Aubobot is expecting - what happens when you do this ?

Craig

Also did you see this other thread ?

Craig

Thank you for the suggestion craig! I tried to ping the IP address of the Aubo but it was unsuccessful and displayed an error that says "Error connecting to PLC: Error: connect EHOSTUNREACH" . However, i am unsure of what SSH and NR box is and i am uncertain of the steps i see online as i am currently new to the network field. Are you able to provide more details on these steps?

What is Node Red running on ? Raspberry PI etc ?

What is the operating system of your Machine that you are workign at ?

Assuming it is Windows 7 or above

You need to download a program called Putty and install it then

Then open it up and create a ss connection to your Node Red

Login to the Node red computer and then at the command line

run

Ping "IP Address of Aubo" and see what reply you get

Craig

hi, sorry for the late reply. I try to use the putty but it shows nothing I have no idea what is wrong and I have found some similar cases like mine, it says it might be PLC not accepting connections anymore, will this possible?

Well it looks like your PLC has plenty of resources available so i do not think that it is an issue there - but it may have some sort of firewall protection - so it could be actively refusing the connection - but you would hope there would be some sort of message to that effect.

I think you still have a network issue.

So as per my other questions

  1. What is Node Red running on ?
  2. It appears you are using a windows PC ?

Craig

our node-red is running on SICK TDC-E
we are using a window PC it is window 7

hi, I just found out that the error connecting to plc is not from the AUBO flow but is another flow


(this is the error connecting to plc from, v1.3.5)

(this is the flow I try on the v1.3.5, but it shows the same result, the connection is unstable and when I debug there is no data shown)
the connection of the AUBO is very unstable, will this be the result of why there is no data shown? I used v1.3.5 and v0.20.3 to try but the result is the same no data coming out and when I debug the node but there is nothing shown

the error at the side is from the other flow. (this is v0.20.3)