Can't instal SQLite on node-red

#1

My Node-red is working fine on my RPI2, but I can't install SQLite!
Here is what I do and what I get.

pi@RPI2:~/.node-red $ sudo npm install node-red-node-sqlite
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

+ node-red-node-sqlite@0.3.5
updated 1 package and audited 1017 packages in 40.703s
found 0 vulnerabilities

pi@RPI2:~/.node-red $

I tried installing it from the node-red "manage pallet" tab.
No errors are returned.
Can anyone help me resolve this issue?
I've also upgraded to the latest versions of everything including n and npm;
sudo n latest
sudo npm install -g npm

#2

Hi @PicoPi

You should not use sudo when installing modules in ~/.node-red as it will muck up your file permissions.

The output you've shared shows a completely successful install of the sqlite module.

Have you restarted Node-RED?

Have you checked the Node-RED log on startup to see if there are any error messages related to the module?

#3

Thanks for the quick rely.
I've rebooted the Pi a couple of times.
where can I check for the log file?

#4

The reason I used sudo was that I got a bunch of permission errors

#5

Which was telling you that you have a larger issue. You most likely need to save you flows, uninstall Node-RED (and possibly Node.JS), certainly remove all your global npm packages and rename your userDir folder (probably ~/.node-red).

Then carefully follow the installation instructions.

Only Node-RED itself needs to be installed globally in a standard installation. If you get errors when installing nodes from the palette, come back to us with the errors and we can help you sort it out.

#6

It was working fine until I decided to install sqlite.
I don't have the knowledge to do all you suggested.
I have a backup of my SD card. I'll revert back to it.
Thanks.

#7

once reverted you should be able to do

cd ~/.node-red
npm i --unsafe-perm node-red-node-sqlite
#8

Sorry for the late response.
This problem you are having is a very common issue.
Please check this answer: Sqlite doesn t work after update about how to install the SQLite node on a Rpi

#9

Thanks for the reply.
I managed to install it from the command line. It does take a long time, but It showed up under "Storage" nodes after that.
Just to make sure and experiment a bit more, I then went back to a fresh install of Rasbian, and this time, installed it from inside Node-Red using "Manage Pallets".
It also worked but took a long time.
Thanks again for the heads up.
~A happy camper